summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorScott Moser <smoser@ubuntu.com>2010-06-17 22:22:39 -0400
committerScott Moser <smoser@ubuntu.com>2010-06-17 22:22:39 -0400
commit22184b7ca3f78808d8025bab5981ed92f8ad99f5 (patch)
tree89c9f4b1991d5f453b7fec5d9239c09adeb7f0f3 /setup.py
parent257da18b16434360e656fe1ef94e4cf8ba3a5210 (diff)
downloadvyos-cloud-init-22184b7ca3f78808d8025bab5981ed92f8ad99f5.tar.gz
vyos-cloud-init-22184b7ca3f78808d8025bab5981ed92f8ad99f5.zip
make cloud-config modules configurable by cloud-config
The list of cloud-config modules is now kept in cloud config itself. There is a builtin list in cloudinit, which is overrideable by /etc/cloud/cloud.cfg or user data cloud-config. This should make the modules more easily added or removed (as no code needs to be edited now) Basic summary of changes: - move CloudConfig.py -> cloudinit/CloudConfig/__init__.py - split cloud-config modules into their own files named cloudinit/CloudConfig/cc_<name>.py - remove all the upstart/cloud-config-* scripts, replacing them with upstart/cloud-config.conf
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 06d60bd4..f15d40f6 100755
--- a/setup.py
+++ b/setup.py
@@ -24,12 +24,12 @@ import os.path
import subprocess
setup(name='cloud-init',
- version='0.5.10',
+ version='0.5.11',
description='EC2 initialisation magic',
author='Scott Moser',
author_email='scott.moser@canonical.com',
url='http://launchpad.net/cloud-init/',
- packages=['cloudinit'],
+ packages=['cloudinit', 'cloudinit.CloudConfig' ],
scripts=['cloud-init.py',
'cloud-init-run-module.py',
'cloud-init-cfg.py'