summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorScott Moser <smoser@ubuntu.com>2011-01-19 03:49:51 +0000
committerScott Moser <smoser@ubuntu.com>2011-01-19 03:49:51 +0000
commit8fbafbddbfbdddcb0a3e087185e432973ac73baa (patch)
treeea53a54e70a0e1a147d16df1c399feb4077e695c /setup.py
parentad5dba4b93f7e45c741f73f88cde1fd0bb59f896 (diff)
downloadvyos-cloud-init-8fbafbddbfbdddcb0a3e087185e432973ac73baa.tar.gz
vyos-cloud-init-8fbafbddbfbdddcb0a3e087185e432973ac73baa.zip
move writing of ssh key fingerprints to a separate tool
This will allow this code to be called more easily elsewhere. I'm considering having the "all the way up" message contain fingerprints so that they're more or less guaranteed to get to the console where the user could see them.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e6a4624a..6ec5a2a1 100755
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,8 @@ setup(name='cloud-init',
('/etc/cloud/templates', glob('templates/*')),
('/etc/init', glob('upstart/*.conf')),
('/usr/share/cloud-init', []),
- ('/usr/lib/cloud-init', ['tools/uncloud-init']),
+ ('/usr/lib/cloud-init',
+ ['tools/uncloud-init', 'tools/write-ssh-key-fingerprints']),
('/usr/share/doc/cloud-init', filter(is_f,glob('doc/*'))),
('/usr/share/doc/cloud-init/examples', filter(is_f,glob('doc/examples/*'))),
('/usr/share/doc/cloud-init/examples/seed', filter(is_f,glob('doc/examples/seed/*'))),