summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Grimm <jon.grimm@canonical.com>2016-11-22 17:09:53 -0600
committerScott Moser <smoser@brickies.net>2016-12-22 17:04:28 -0500
commitb2a9f33616c806ae6e052520a8589113308f567c (patch)
treee24d64e56104dfa1b608a9f255c9b8f618e45cc0 /setup.py
parent0b0f254a6935a1b1fff128fa177152dd519e1a3d (diff)
downloadvyos-cloud-init-b2a9f33616c806ae6e052520a8589113308f567c.tar.gz
vyos-cloud-init-b2a9f33616c806ae6e052520a8589113308f567c.zip
LICENSE: Allow dual licensing GPL-3 or Apache 2.0
This has been a recurring ask and we had initially just made the change to the cloud-init 2.0 codebase. As the current thinking is we'll just continue to enhance the current codebase, its desirable to relicense to match what we'd intended as part of the 2.0 plan here. - put a brief description of license in LICENSE file - put full license versions in LICENSE-GPLv3 and LICENSE-Apache2.0 - simplify the per-file header to reference LICENSE - tox: ignore H102 (Apache License Header check) Add license header to files that ship. Reformat headers, make sure everything has vi: at end of file. Non-shipping files do not need the copyright header, but at the moment tests/ have it.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py30
1 files changed, 10 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index 8ff667d5..04036078 100755
--- a/setup.py
+++ b/setup.py
@@ -1,24 +1,12 @@
-# vi: ts=4 expandtab
-#
-# Distutils magic for ec2-init
-#
-# Copyright (C) 2009 Canonical Ltd.
-# Copyright (C) 2012 Yahoo! Inc.
-#
-# Author: Soren Hansen <soren@canonical.com>
-# Author: Joshua Harlow <harlowja@yahoo-inc.com>
+# Copyright (C) 2009 Canonical Ltd.
+# Copyright (C) 2012 Yahoo! Inc.
#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License version 3, as
-# published by the Free Software Foundation.
+# Author: Soren Hansen <soren@canonical.com>
+# Author: Joshua Harlow <harlowja@yahoo-inc.com>
#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# This file is part of cloud-init. See LICENSE file for license information.
+
+# Distutils magic for ec2-init
from glob import glob
@@ -209,7 +197,7 @@ setuptools.setup(
url='http://launchpad.net/cloud-init/',
packages=setuptools.find_packages(exclude=['tests']),
scripts=['tools/cloud-init-per'],
- license='GPLv3',
+ license='Dual-licensed under GPLv3 or Apache 2.0',
data_files=data_files,
install_requires=requirements,
cmdclass=cmdclass,
@@ -219,3 +207,5 @@ setuptools.setup(
],
}
)
+
+# vi: ts=4 expandtab