summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorharlowja <harlowja@virtualbox.rhel>2012-06-26 07:47:29 -0700
committerharlowja <harlowja@virtualbox.rhel>2012-06-26 07:47:29 -0700
commiteb74655ae9826dcde235f1849b50e7d5a2b02223 (patch)
tree8cf24af2485bd0b84576b3166d1e6bea570908a0 /setup.py
parent84c50b0c5273d96cdd54e9a63d59357f62eb8364 (diff)
downloadvyos-cloud-init-eb74655ae9826dcde235f1849b50e7d5a2b02223.tar.gz
vyos-cloud-init-eb74655ae9826dcde235f1849b50e7d5a2b02223.zip
Add all the upstart/systemd/init.d files.
Let the package building solutions figure out exactly which of these they wish to delete or wish to take, since setup.py can not know it just has to install them all.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index fd67da46..402443ea 100755
--- a/setup.py
+++ b/setup.py
@@ -67,7 +67,11 @@ setuptools.setup(name='cloud-init',
('/etc/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')),
('/etc/cloud/templates', glob('templates/*')),
# Only really need for upstart based systems
- #('/etc/init', glob('upstart/*.conf')),
+ ('/etc/init', glob('upstart/*.conf')),
+ # Only really need for systemd based systems
+ ('/etc/systemd/system', glob('systemd/*.service')),
+ # Only really need for init.d based system
+ ('/etc/init.d', glob('initd/*')),
('/usr/share/cloud-init', []),
('/usr/lib/cloud-init',
['tools/uncloud-init', 'tools/write-ssh-key-fingerprints']),