diff options
author | Barry Warsaw <barry@python.org> | 2015-01-21 15:28:32 -0500 |
---|---|---|
committer | Barry Warsaw <barry@python.org> | 2015-01-21 15:28:32 -0500 |
commit | 463d626ba53e54160f350d84831e1877b24f4024 (patch) | |
tree | e13078db48bf17c062ced1ce1feed78ddd3a9da0 /setup.py | |
parent | ee4a174e2e3b3268ef95485b99d81edea1ca3458 (diff) | |
download | vyos-cloud-init-463d626ba53e54160f350d84831e1877b24f4024.tar.gz vyos-cloud-init-463d626ba53e54160f350d84831e1877b24f4024.zip |
Only install cheetah (and only run the cheetah templating test) when in Python
2. Cheetah is not compatible with Python 3.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -175,6 +175,11 @@ else: } +requirements = read_requires() +if sys.version_info < (3,): + requirements.append('cheetah') + + setuptools.setup(name='cloud-init', version=get_version(), description='EC2 initialisation magic', @@ -187,6 +192,6 @@ setuptools.setup(name='cloud-init', ], license='GPLv3', data_files=data_files, - install_requires=read_requires(), + install_requires=requirements, cmdclass=cmdclass, ) |