summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSoren Hansen <soren@canonical.com>2009-06-26 13:57:27 +0200
committerSoren Hansen <soren@canonical.com>2009-06-26 13:57:27 +0200
commitb098228ab03003218b894855142dec9a8f406cfb (patch)
treeefd52bd8ab547fd1b61406a68cb1eb5f0d2e2042 /setup.py
parentbb5711688e7f6b2abe4e82a5b5233194a323b99d (diff)
downloadvyos-cloud-init-b098228ab03003218b894855142dec9a8f406cfb.tar.gz
vyos-cloud-init-b098228ab03003218b894855142dec9a8f406cfb.zip
* Distutils added
* New ec2init python module introduced * Lots and lots of stuff cleaned up and moved to ec2init python module. * Started the move to Boto
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 00000000..851e559f
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+from distutils.core import setup
+from glob import glob
+import os.path
+import subprocess
+
+setup(name='EC2-init',
+ version='0.5',
+ description='EC2 initialisation magic',
+ author='Soren Hansen',
+ author_email='soren@canonical.com',
+ url='http://launchpad.net/ec2-init/',
+ packages=['ec2init'],
+ scripts=['ec2-fetch-credentials.py',
+ 'ec2-get-info.py',
+ 'ec2-run-user-data.py',
+ 'ec2-set-apt-sources.py',
+ 'ec2-set-defaults.py',
+ 'ec2-set-hostname.py'],
+ data_files=[('/etc/ec2-init', ['debian/ec2-config.cfg']),
+ ('/etc/ec2-init/templates', glob('templates/*'))],
+ )