summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog22
-rw-r--r--debian/control4
-rw-r--r--debian/ec2-config.cfg1
-rw-r--r--debian/init16
-rw-r--r--debian/install3
5 files changed, 26 insertions, 20 deletions
diff --git a/debian/changelog b/debian/changelog
index 94c79b83..736e0b82 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,15 +1,21 @@
+ec2-init (0.3.3ubuntu11) jaunty; urgency=low
+
+ * debian/control:
+ - Add python-cheetah and python-apt as a dependency.
+ * debian/ec2-config.cfg:
+ - Remove distro due to the change in ec2-set-apt-sources.py
+ * debian/inistall
+ - Install the templates in the right place.
+ * ec2-set-apt-sources.py:
+ - Use python-apt to update the sources.list.
+
+ -- Chuck Short <zulcss@ubuntu.com> Wed, 01 Apr 2009 13:58:43 -0400
+
ec2-init (0.3.3ubuntu10) jaunty; urgency=low
* ec2-set-hostname.py:
- Use template for /etc/hosts creation.
- - Dont use public_hostname in /etc/hosts. (LP: #352745)
- * debian/control:
- - Add python-cheetah as a depends.
- * templates/sources.list.tmpl:
- - Update template.
- * debian/init:
- - Run the ec2-user-data script last so that the users
- get a stable system before running the user scripts.
+ - Dont use public_hostname in /etc/hosts. (LP: #352745)
-- Chuck Short <zulcss@ubuntu.com> Wed, 01 Apr 2009 08:48:05 -0400
diff --git a/debian/control b/debian/control
index 05823938..e51482e0 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Standards-Version: 3.8.0
Package: ec2-init
Architecture: i386 amd64
-Depends: python, procps, python-configobj, python-cheetah
-Description: Init scripts for EC2 instances
+Depends: python, procps, python-configobj, python-cheetah, python-apt
+Description: Init scripts for EC2 instances,
EC2 instances need special scripts to run during initialisation
to retrieve and install ssh keys and to let the user run various scripts.
diff --git a/debian/ec2-config.cfg b/debian/ec2-config.cfg
index ebf5eb69..76c81b77 100644
--- a/debian/ec2-config.cfg
+++ b/debian/ec2-config.cfg
@@ -1,3 +1,2 @@
user="ubuntu"
-distro="jaunty"
DISABLE_ROOT="1"
diff --git a/debian/init b/debian/init
index 113d8700..ea4f0acf 100644
--- a/debian/init
+++ b/debian/init
@@ -38,6 +38,14 @@ case "$1" in
log_end_msg 1
fi
+ log_daemon_msg "Running EC2 user data"
+ if ec2-run-user-data 2>&1 | logger -t "user-data"
+ then
+ log_end_msg 0
+ else
+ log_end_msg 1
+ fi
+
log_daemon_msg "Setting hostname to EC2 public_hostname"
if ec2-set-hostname 2> /dev/null
then
@@ -53,14 +61,6 @@ case "$1" in
log_end_msg 1
fi
- log_daemon_msg "Running EC2 user data"
- if ec2-run-user-data 2>&1 | logger -t "user-data"
- then
- log_end_msg 0
- else
- log_end_msg 1
- fi
-
;;
stop)
exit 0
diff --git a/debian/install b/debian/install
index c2aa8811..33e2382f 100644
--- a/debian/install
+++ b/debian/install
@@ -1,2 +1,3 @@
debian/tmp/usr/sbin/*
-debian/tmp/etc/ec2-init/*
+debian/tmp/etc/ec2-init/templates/*
+debian/ec2-config.cfg etc/ec2-init