summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog20
-rw-r--r--debian/dirs2
-rw-r--r--debian/init14
3 files changed, 26 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 6b2006a9..1f720438 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,23 @@
+ec2-init (0.3.2) jaunty; urgency=low
+
+ * debian/init:
+ - Remove already ran detection
+ - Log the running of ec2-run-user-data to /var/log/ec2-user-data.log
+ * ec2-set-hostname.py:
+ - set hostname to the Ec2 local-hostname
+ - Update the /etc/hosts to change the ubuntu hostname to the
+ public hostname.
+ * ec2-fetch-credentials:
+ - Copy the ssh keys to the ubuntu user.
+ - Setup authorized keys for root to tell the user to login as the
+ ubuntu user when they try to connect.
+ * ec2-run-user-data:
+ - Create an .already-ran file to check to see if ec2-run-user-data
+ already ran.
+ - Save the ec2-run-user-data script in /var/ec2.
+
+ -- Chuck Short <zulcss@ubuntu.com> Wed, 04 Feb 2009 09:32:08 -0500
+
ec2-init (0.3.1) jaunty; urgency=low
* debian/dir: Install /var/ec2 to save user-data scripts.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 00000000..19be79b3
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+var/ec2
+usr/sbin
diff --git a/debian/init b/debian/init
index 24db3845..e28edd06 100644
--- a/debian/init
+++ b/debian/init
@@ -1,7 +1,7 @@
#!/bin/sh
### BEGIN INIT INFO
# Provides: ec2-init
-# Required-Start: $network $local_fs
+# Required-Start: $network $local_fs $ssh
# Required-Stop:
# Should-Start: $named
# Should-Stop:
@@ -27,17 +27,11 @@ case "$1" in
fi
log_daemon_msg "Running EC2 user data"
- if [ -f /var/ec2/.already_ran ]
+ if ec2-run-user-data 2>&1 | tee /var/log/ec2-user-data.log
then
- echo "Already ran";
+ log_end_msg 0
else
- if ec2-run-user-data 2> /dev/null
- then
- log_end_msg 0
- touch /var/ec2/.already_ran
- else
- log_end_msg 1
- fi
+ log_end_msg 1
fi
if pgrep nash-hotplug > /dev/null