summaryrefslogtreecommitdiff
path: root/packages/debian/rules.in
diff options
context:
space:
mode:
Diffstat (limited to 'packages/debian/rules.in')
-rwxr-xr-xpackages/debian/rules.in14
1 files changed, 9 insertions, 5 deletions
diff --git a/packages/debian/rules.in b/packages/debian/rules.in
index bb2e1d5c..cf2dd405 100755
--- a/packages/debian/rules.in
+++ b/packages/debian/rules.in
@@ -1,9 +1,8 @@
## template:basic
#!/usr/bin/make -f
-
INIT_SYSTEM ?= upstart,systemd
-PYVER ?= python${pyver}
export PYBUILD_INSTALL_ARGS=--init-system=$(INIT_SYSTEM)
+PYVER ?= python${pyver}
%:
dh $@ --with $(PYVER),systemd --buildsystem pybuild
@@ -14,6 +13,11 @@ override_dh_install:
cp tools/21-cloudinit.conf debian/cloud-init/etc/rsyslog.d/21-cloudinit.conf
override_dh_auto_test:
- # Because setup tools didn't copy data...
- [ ! -d .pybuild/pythonX.Y_?.?/build/tests ] || cp -r tests/data .pybuild/pythonX.Y_?.?/build/tests
- http_proxy= dh_auto_test -- --test-nose
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+ http_proxy= make PYVER=${pyver} check
+else
+ @echo check disabled by DEB_BUILD_OPTIONS=$(DEB_BUILD_OPTIONS)
+endif
+
+override_dh_systemd_start:
+ dh_systemd_start --no-restart-on-upgrade --no-start