summaryrefslogtreecommitdiff
path: root/packages/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'packages/debian/rules')
-rwxr-xr-xpackages/debian/rules17
1 files changed, 0 insertions, 17 deletions
diff --git a/packages/debian/rules b/packages/debian/rules
deleted file mode 100755
index 9e0c5ddb..00000000
--- a/packages/debian/rules
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/usr/bin/make -f
-
-INIT_SYSTEM ?= upstart,systemd
-export PYBUILD_INSTALL_ARGS=--init-system=$(INIT_SYSTEM)
-
-%:
- dh $@ --with python2,systemd --buildsystem pybuild
-
-override_dh_install:
- dh_install
- install -d debian/cloud-init/etc/rsyslog.d
- cp tools/21-cloudinit.conf debian/cloud-init/etc/rsyslog.d/21-cloudinit.conf
-
-override_dh_auto_test:
- # Becuase setup tools didn't copy data...
- cp -r tests/data .pybuild/pythonX.Y_2.7/build/tests
- http_proxy= dh_auto_test -- --test-nose