summaryrefslogtreecommitdiff
path: root/packages/debian
diff options
context:
space:
mode:
Diffstat (limited to 'packages/debian')
-rw-r--r--packages/debian/changelog5
-rw-r--r--packages/debian/compat1
-rw-r--r--packages/debian/control29
-rw-r--r--packages/debian/copyright51
-rw-r--r--packages/debian/dirs5
-rw-r--r--packages/debian/pycompat1
-rwxr-xr-xpackages/debian/rules27
7 files changed, 119 insertions, 0 deletions
diff --git a/packages/debian/changelog b/packages/debian/changelog
new file mode 100644
index 00000000..ac5bcf98
--- /dev/null
+++ b/packages/debian/changelog
@@ -0,0 +1,5 @@
+cloud-init ({{version}}~{{revision}}-1) UNRELEASED; urgency=low
+
+ * build
+
+ -- Scott Moser <smoser@ubuntu.com> Fri, 16 Dec 2011 11:50:25 -0500
diff --git a/packages/debian/compat b/packages/debian/compat
new file mode 100644
index 00000000..7ed6ff82
--- /dev/null
+++ b/packages/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/packages/debian/control b/packages/debian/control
new file mode 100644
index 00000000..e00901af
--- /dev/null
+++ b/packages/debian/control
@@ -0,0 +1,29 @@
+Source: cloud-init
+Section: admin
+Priority: extra
+Maintainer: Scott Moser <smoser@ubuntu.com>
+Build-Depends: cdbs,
+ debhelper (>= 5.0.38),
+ python (>= 2.6.6-3~),
+ python-nose,
+ pyflakes,
+ pylint,
+ python-mocker,
+XS-Python-Version: all
+Standards-Version: 3.9.3
+
+Package: cloud-init
+Architecture: all
+Depends: cloud-utils,
+ procps,
+ python,
+{{for r in requires}}
+ {{r}},
+{{endfor}}
+ python-software-properties,
+ ${misc:Depends},
+ ${python:Depends}
+XB-Python-Version: ${python:Versions}
+Description: Init scripts for cloud instances
+ Cloud instances need special scripts to run during initialisation
+ to retrieve and install ssh keys and to let the user run various scripts.
diff --git a/packages/debian/copyright b/packages/debian/copyright
new file mode 100644
index 00000000..dc993525
--- /dev/null
+++ b/packages/debian/copyright
@@ -0,0 +1,51 @@
+Format-Specification: http://svn.debian.org/wsvn/dep/web/deps/dep5.mdwn?op=file&rev=135
+Name: cloud-init
+Maintainer: Scott Moser <scott.moser@canonical.com>
+Source: https://launchpad.net/cloud-init
+
+This package was debianized by Soren Hansen <soren@ubuntu.com> on
+Thu, 04 Sep 2008 12:49:15 +0200 as ec2-init. It was later renamed to
+cloud-utils by Scott Moser <scott.moser@canonical.com>
+
+Upstream Author: Scott Moser <smoser@canonical.com>
+ Soren Hansen <soren@canonical.com>
+ Chuck Short <chuck.short@canonical.com>
+
+Copyright: 2010, Canonical Ltd.
+License: GPL-3
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License version 3, as
+ published by the Free Software Foundation.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+ The complete text of the GPL version 3 can be seen in
+ /usr/share/common-licenses/GPL-3.
+
+Files: cloudinit/boto_utils.py
+Copyright: 2006,2007, Mitch Garnaat http://garnaat.org/
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation the rights to use, copy, modify, merge, publish, dis-
+ tribute, sublicense, and/or sell copies of the Software, and to permit
+ persons to whom the Software is furnished to do so, subject to the fol-
+ lowing conditions:
+
+ The above copyright notice and this permission notice shall be included
+ in all copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABIL-
+ ITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+ SHALL THE AUTHOR BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+ IN THE SOFTWARE.
diff --git a/packages/debian/dirs b/packages/debian/dirs
new file mode 100644
index 00000000..f3de468d
--- /dev/null
+++ b/packages/debian/dirs
@@ -0,0 +1,5 @@
+var/lib/cloud
+usr/bin
+etc/init
+usr/share/doc/cloud
+etc/cloud
diff --git a/packages/debian/pycompat b/packages/debian/pycompat
new file mode 100644
index 00000000..0cfbf088
--- /dev/null
+++ b/packages/debian/pycompat
@@ -0,0 +1 @@
+2
diff --git a/packages/debian/rules b/packages/debian/rules
new file mode 100755
index 00000000..a907b594
--- /dev/null
+++ b/packages/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+DEB_PYTHON2_MODULE_PACKAGES = cloud-init
+
+binary-install/cloud-init::cloud-init-fixups
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
+
+DEB_DH_INSTALL_SOURCEDIR := debian/tmp
+
+cloud-init-fixups:
+ install -d $(DEB_DESTDIR)/etc/rsyslog.d
+ cp tools/21-cloudinit.conf $(DEB_DESTDIR)/etc/rsyslog.d/21-cloudinit.conf
+
+# You only need to run this immediately after checking out the package from
+# revision control.
+# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=572204
+quilt-setup:
+ @[ ! -d .pc ] || { echo ".pc exists. remove it and re-run to start fresh"; exit 1; }
+ set -e; for patch in $$(quilt series | tac); do \
+ patch -p1 -R --no-backup-if-mismatch <"debian/patches/$$patch"; \
+ done
+ quilt push -a
+
+.PHONY: quilt-setup
+