summaryrefslogtreecommitdiff
path: root/packages/debian
diff options
context:
space:
mode:
Diffstat (limited to 'packages/debian')
-rw-r--r--packages/debian/compat2
-rw-r--r--packages/debian/control.in12
-rw-r--r--packages/debian/pycompat1
-rwxr-xr-xpackages/debian/rules25
4 files changed, 21 insertions, 19 deletions
diff --git a/packages/debian/compat b/packages/debian/compat
index 7ed6ff82..ec635144 100644
--- a/packages/debian/compat
+++ b/packages/debian/compat
@@ -1 +1 @@
-5
+9
diff --git a/packages/debian/control.in b/packages/debian/control.in
index 7e42b94b..18a4600c 100644
--- a/packages/debian/control.in
+++ b/packages/debian/control.in
@@ -1,10 +1,11 @@
## This is a cheetah template
Source: cloud-init
Section: admin
-Priority: extra
+Priority: optional
Maintainer: Scott Moser <smoser@ubuntu.com>
-Build-Depends: cdbs,
- debhelper (>= 5.0.38),
+Build-Depends: debhelper (>= 9),
+ dh-python,
+ dh-systemd,
python (>= 2.6.6-3~),
python-nose,
pyflakes,
@@ -12,7 +13,10 @@ Build-Depends: cdbs,
python-setuptools,
python-cheetah,
python-mocker,
- python-setuptools
+ python-httpretty,
+#for $r in $requires
+ ${r},
+#end for
XS-Python-Version: all
Standards-Version: 3.9.3
diff --git a/packages/debian/pycompat b/packages/debian/pycompat
deleted file mode 100644
index 0cfbf088..00000000
--- a/packages/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/packages/debian/rules b/packages/debian/rules
index 7623ac9d..9e0c5ddb 100755
--- a/packages/debian/rules
+++ b/packages/debian/rules
@@ -1,18 +1,17 @@
#!/usr/bin/make -f
-DEB_PYTHON2_MODULE_PACKAGES = cloud-init
-INIT_SYSTEM ?= upstart
+INIT_SYSTEM ?= upstart,systemd
+export PYBUILD_INSTALL_ARGS=--init-system=$(INIT_SYSTEM)
-binary-install/cloud-init::cloud-init-fixups
+%:
+ dh $@ --with python2,systemd --buildsystem pybuild
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/python-distutils.mk
+override_dh_install:
+ dh_install
+ install -d debian/cloud-init/etc/rsyslog.d
+ cp tools/21-cloudinit.conf debian/cloud-init/etc/rsyslog.d/21-cloudinit.conf
-DEB_PYTHON_INSTALL_ARGS_ALL += --init-system=$(INIT_SYSTEM)
-
-DEB_DH_INSTALL_SOURCEDIR := debian/tmp
-
-cloud-init-fixups:
- install -d $(DEB_DESTDIR)/etc/rsyslog.d
- cp tools/21-cloudinit.conf $(DEB_DESTDIR)/etc/rsyslog.d/21-cloudinit.conf
-
+override_dh_auto_test:
+ # Becuase setup tools didn't copy data...
+ cp -r tests/data .pybuild/pythonX.Y_2.7/build/tests
+ http_proxy= dh_auto_test -- --test-nose