summaryrefslogtreecommitdiff
path: root/packages/redhat/cloud-init.spec.in
diff options
context:
space:
mode:
Diffstat (limited to 'packages/redhat/cloud-init.spec.in')
-rw-r--r--packages/redhat/cloud-init.spec.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/packages/redhat/cloud-init.spec.in b/packages/redhat/cloud-init.spec.in
index 35b27beb..30bcd050 100644
--- a/packages/redhat/cloud-init.spec.in
+++ b/packages/redhat/cloud-init.spec.in
@@ -5,9 +5,13 @@
# Or: http://fedoraproject.org/wiki/Packaging:ScriptletSnippets
# Or: http://www.rpm.org/max-rpm/ch-rpm-inside.html
+#for $d in $defines
+%define ${d}
+#end for
+
Name: cloud-init
Version: ${version}
-Release: ${release}%{?dist}
+Release: ${release}${subrelease}%{?dist}
Summary: Cloud instance init scripts
Group: System Environment/Base
@@ -36,6 +40,13 @@ Requires: shadow-utils
Requires: ${r}
#end for
+# Custom patches
+#set $size = 0
+#for $p in $patches
+Patch${size}: $p
+#set $size += 1
+#end for
+
#if $sysvinit
Requires(post): chkconfig
Requires(postun): initscripts
@@ -58,6 +69,13 @@ ssh keys and to let the user run various scripts.
%prep
%setup -q -n %{name}-%{version}~${release}
+# Custom patches activation
+#set $size = 0
+#for $p in $patches
+%patch${size} -p1
+#set $size += 1
+#end for
+
%build
%{__python} setup.py build