summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2010-05-24 22:11:06 +0200
committerDaniel Baumann <daniel@debian.org>2010-05-30 09:42:24 +0200
commitf496e2dd4deab77bbc172304d80010c6ec3d35c7 (patch)
treec301c1ec19c70c1b100cf5a905535c3ff005b96e
parent229d0d183c08ec11f941f1de56789b24d637ed31 (diff)
downloadvyos-live-build-f496e2dd4deab77bbc172304d80010c6ec3d35c7.tar.gz
vyos-live-build-f496e2dd4deab77bbc172304d80010c6ec3d35c7.zip
Simplyfing makefile a bit.
-rw-r--r--Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 3b2caac03..440634c5f 100644
--- a/Makefile
+++ b/Makefile
@@ -4,12 +4,14 @@ SHELL := sh -e
LANGUAGES = de
+SCRIPTS = live-helper.sh cgi/* functions/* examples/*/*.sh helpers/* hooks/*
+
all: test build
test:
@echo -n "Checking for syntax errors"
- @for SCRIPT in live-helper.sh cgi/* functions/* examples/*/*.sh helpers/* hooks/*; \
+ @for SCRIPT in $(SCRIPTS); \
do \
sh -n $${SCRIPT}; \
echo -n "."; \
@@ -17,13 +19,14 @@ test:
@echo " done."
+ @# We can't just fail yet on bashisms (FIXME)
@echo -n "Checking for bashisms"
@if [ -x /usr/bin/checkbashisms ]; \
then \
- for SCRIPT in live-helper.sh functions/* examples/*/*.sh helpers/* hooks/*; \
+ for SCRIPT in $(SCRIPTS); \
do \
- checkbashisms $${SCRIPT}; \
+ checkbashisms $${SCRIPT} || true; \
echo -n "."; \
done; \
else \