summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2007-11-11 11:09:33 +0100
committerDaniel Baumann <daniel@debian.org>2011-03-09 18:22:28 +0100
commitb6965a492b91eddfdbb46170f47e8cc6286bb4a9 (patch)
tree77288603fff7b351910477f0062831a2af23246c
parent8a2a37bd282ec195f192e0de9a160fd6df03fc47 (diff)
downloadvyos-live-build-b6965a492b91eddfdbb46170f47e8cc6286bb4a9.tar.gz
vyos-live-build-b6965a492b91eddfdbb46170f47e8cc6286bb4a9.zip
Adding custom reportbug script.
-rw-r--r--debian/bug/script7
-rwxr-xr-xdebian/rules3
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/bug/script b/debian/bug/script
new file mode 100644
index 000000000..963a5f76b
--- /dev/null
+++ b/debian/bug/script
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# Checking depends
+dpkg -l debootstrap cdebootstrap
+
+# Checking suggests
+dpkg -l dosfstools genisoimage memtest86+ memtest86 mtools parted squashfs-tools genext2fs sudo fakeroot syslinux grub
diff --git a/debian/rules b/debian/rules
index 0da777ec3..cc8778982 100755
--- a/debian/rules
+++ b/debian/rules
@@ -37,6 +37,9 @@ install: build
rm -f debian/live-helper/usr/share/doc/live-helper/ChangeLog
mv debian/live-helper/usr/share/doc/live-helper/ChangeLog.live-package debian/live-helper/usr/share/doc/live-helper/changelog.live-package
+ # Installing bug control
+ install -D -m 0755 debian/bug/script debian/live-helper/usr/share/bug/live-helper
+
binary-arch: build install
binary-indep: build install