summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRaphaël Hertzog <hertzog@debian.org>2016-12-02 15:21:50 +0100
committerRaphaël Hertzog <hertzog@debian.org>2016-12-02 15:23:20 +0100
commitb8f7f19015055fc4c7ef30e3787721ac2218ed3b (patch)
tree6f2bc8be3148f843545d986a543b7bf2ea526aa5 /debian/rules
parent7ad6c408e559a1755beb63db8186e002a56bb7a7 (diff)
downloadvyos-live-build-b8f7f19015055fc4c7ef30e3787721ac2218ed3b.tar.gz
vyos-live-build-b8f7f19015055fc4c7ef30e3787721ac2218ed3b.zip
Fix version of live-build that is displayed by lb --version
Now we generate the VERSION file at install time or at package build time.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 2d2e62735..92cbff285 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,16 @@
#!/usr/bin/make -f
+include /usr/share/dpkg/pkg-info.mk
+
%:
dh $@
override_dh_auto_install:
dh_auto_install -- DESTDIR=debian/live-build
+ # Update VERSION file
+ echo $(DEB_VERSION) >debian/live-build/usr/share/live/build/VERSION
+
# Removing unused files
rm -f debian/live-build/usr/share/doc/live-build/COPYING