summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2009-11-22 14:36:42 +0100
committerDaniel Baumann <daniel@debian.org>2009-11-22 14:38:00 +0100
commita62f12110b19a52a58d7eae871012202cfa16055 (patch)
tree0bd188079c808ee8956fb5304c46ce8266b49f75 /debian/rules
downloadvyos-live-build-a62f12110b19a52a58d7eae871012202cfa16055.tar.gz
vyos-live-build-a62f12110b19a52a58d7eae871012202cfa16055.zip
Renaming categories to archive areas (Closes: #519690).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules61
1 files changed, 61 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..4b7ce63ae
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,61 @@
+#!/usr/bin/make -f
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ $(MAKE) -C po clean
+
+ dh_clean
+
+build:
+ $(MAKE) test
+ $(MAKE) -C po update-po
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_prep
+ dh_installdirs
+
+ # Installing package
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/live-helper
+
+ # Installing message catalogs
+ $(MAKE) -C po install DESTDIR=$(CURDIR)/debian/live-helper
+
+ install -D -m 0644 debian/live-helper.default debian/live-helper/etc/default/live-helper_autobuild
+
+ # Preparing alternatives
+ mv debian/live-helper/usr/share/live-helper/includes debian/live-helper/usr/share/live-helper/includes.debian
+ mv debian/live-helper/usr/share/live-helper/templates debian/live-helper/usr/share/live-helper/templates.debian
+
+ # Removing double files
+ rm -f debian/live-helper/usr/share/doc/live-helper/COPYING
+ rm -f debian/live-helper/usr/share/doc/live-helper/ChangeLog
+ mv debian/live-helper/usr/share/doc/live-helper/ChangeLog.live-package debian/live-helper/usr/share/doc/live-helper/changelog.live-package
+
+ # Installing bug control
+ install -D -m 0644 debian/bug/live-helper.presubj debian/live-helper/usr/share/bug/live-helper/presubj
+ install -D -m 0755 debian/bug/live-helper.script debian/live-helper/usr/share/bug/live-helper/script
+
+binary: binary-indep
+
+binary-arch:
+
+binary-indep: install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs docs/ChangeLog
+ dh_installdocs
+ dh_installlogrotate
+ dh_installcron
+ dh_installman
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+.PHONY: clean build install binary binary-arch binary-indep