summaryrefslogtreecommitdiff
path: root/frontend/live-build
diff options
context:
space:
mode:
authorjohnraff <github@rafflesnagoya.com>2020-05-01 11:23:39 +0900
committerRaphaƫl Hertzog <hertzog@debian.org>2020-05-01 09:59:11 +0000
commit0e5d0483e5596e200430d28356b808af76806439 (patch)
tree66ea8d81afc59322bedce8c738f32fa737877bd1 /frontend/live-build
parentfd18d46e0eb6abfe757f8764c65ac4c472fcdeef (diff)
downloadvyos-live-build-0e5d0483e5596e200430d28356b808af76806439.tar.gz
vyos-live-build-0e5d0483e5596e200430d28356b808af76806439.zip
Replace 'which' with 'command -v' to test for the existance of an executable
This is considered to be more robust. Two instances remain: scripts/build/chroot_archives, line 257: if [ "${LB_APT}" = "aptitude" ] && [ ! $(Chroot chroot "which aptitude") ] The command is run inside a chroot where the environment might be special, and would need further testing. manpages/Makefile, line 42: @if [ ! -x "$$(which po4a 2>/dev/null)" ]; \ I am insufficiently familiar with makefile syntax to edit this.
Diffstat (limited to 'frontend/live-build')
-rwxr-xr-xfrontend/live-build2
1 files changed, 1 insertions, 1 deletions
diff --git a/frontend/live-build b/frontend/live-build
index 29efec9cf..2980158c0 100755
--- a/frontend/live-build
+++ b/frontend/live-build
@@ -23,7 +23,7 @@
set -e
-if [ $(which man) ]
+if command -v man >/dev/null
then
man live-build
else