summaryrefslogtreecommitdiff
path: root/frontend
diff options
context:
space:
mode:
authorjohnraff <github@rafflesnagoya.com>2020-03-12 14:37:21 +0900
committerLuca Boccassi <bluca@debian.org>2020-03-12 10:35:57 +0000
commit2d9ab1f7f82f9a98b97d1503c1e3f31c86061c15 (patch)
tree7e387db7a374aad1f0865147c0b3403e09c77ce3 /frontend
parent72a87fb70d26153bdfe06d0cdf42a199ff7ad68d (diff)
downloadvyos-live-build-2d9ab1f7f82f9a98b97d1503c1e3f31c86061c15.tar.gz
vyos-live-build-2d9ab1f7f82f9a98b97d1503c1e3f31c86061c15.zip
Test for executables: replace 'which' with more robust 'command -v'
Instances of: if [ $(which <command> ] have been replaced with: if command -v <command> >/dev/null which is considered to be more robust in a range of environments. scripts/build/chroot_archives: line 259: if [ "${LB_APT}" = "aptitude" ] && [ ! $(Chroot chroot "which aptitude") ] has been left untouched because the chroot might require a more complex command which would need more testing. manpages/Makefile: line 42: @if [ ! -x "$$(which po4a 2>/dev/null)" ]; \ has been left untouched because I am not sufficiently familiar with makefiles.
Diffstat (limited to 'frontend')
-rwxr-xr-xfrontend/lb4
-rwxr-xr-xfrontend/live-build2
2 files changed, 3 insertions, 3 deletions
diff --git a/frontend/lb b/frontend/lb
index 464b07dcc..993d3a27d 100755
--- a/frontend/lb
+++ b/frontend/lb
@@ -21,7 +21,7 @@ USAGE="lb {clean|config|build}"
case "${1}" in
-h|--help)
- if [ $(which man) ]
+ if command -v man >/dev/null
then
man lb
exit 0
@@ -76,7 +76,7 @@ case "${1}" in
then
# User has live-build installed in the system
SCRIPT=/usr/lib/live/build/"${COMMAND}"
- elif [ $(which "${COMMAND}") ]
+ elif command -v "${COMMAND}" >/dev/null
then
# User has live-build commands in path
SCRIPT="${COMMAND}"
diff --git a/frontend/live-build b/frontend/live-build
index 29efec9cf..2980158c0 100755
--- a/frontend/live-build
+++ b/frontend/live-build
@@ -23,7 +23,7 @@
set -e
-if [ $(which man) ]
+if command -v man >/dev/null
then
man live-build
else