summaryrefslogtreecommitdiff
path: root/frontends/cgi/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2012-06-05 20:25:23 +0200
committerDaniel Baumann <daniel@debian.org>2012-06-06 19:59:13 +0200
commit2c5004a3583c3535e7d40d5eacad0b3b876b65b0 (patch)
tree89fc773984d5d32f5a400d83a2a90d1728ae988c /frontends/cgi/Makefile
parente906e7846210ef27e75dd35c65156d22d9c5ae23 (diff)
downloadvyos-live-build-2c5004a3583c3535e7d40d5eacad0b3b876b65b0.tar.gz
vyos-live-build-2c5004a3583c3535e7d40d5eacad0b3b876b65b0.zip
Re-arranging frontends in source tree.
Diffstat (limited to 'frontends/cgi/Makefile')
-rw-r--r--frontends/cgi/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/frontends/cgi/Makefile b/frontends/cgi/Makefile
new file mode 100644
index 000000000..8ac08ddac
--- /dev/null
+++ b/frontends/cgi/Makefile
@@ -0,0 +1,21 @@
+# Makefile
+
+install:
+ install -D -m 0755 live-build-cgi $(DESTDIR)/usr/lib/cgi-bin/live-build
+ install -D -m 0755 live-build-cgi.cron $(DESTDIR)/etc/cron.hourly/live-build-cgi
+ install -D -m 0644 live-build-cgi.crontab $(DESTDIR)/etc/cron.d/live-build-cgi
+ install -D -m 0644 live-build-cgi.default $(DESTDIR)/etc/default/live-build-cgi
+ install -D -m 0644 live-build-cgi.logrotate $(DESTDIR)/etc/logrotate.d/live-build-cgi
+
+ install -d -m 0755 $(DESTDIR)/var/log
+ touch $(DESTDIR)/var/log/live
+ chown www-data:www-data $(DESTDIR)/var/log/live
+
+uninstall:
+ rm -f $(DESTDIR)/usr/lib/cgi-bin/live-build
+ rm -f $(DESTDIR)/etc/cron.d/live-build-cgi
+ rm -f $(DESTDIR)/etc/cron.hourly/live-build-cgi
+ rm -f $(DESTDIR)/etc/default/live-build-cgi
+ rm -f $(DESTDIR)/etc/logrotate.d/live-build-cgi
+
+reinstall: uninstall install