summaryrefslogtreecommitdiff
path: root/functions/architectures.sh
diff options
context:
space:
mode:
authorjohnraff <github@rafflesnagoya.com>2020-03-12 14:37:21 +0900
committerLuca Boccassi <bluca@debian.org>2020-03-12 10:35:57 +0000
commit2d9ab1f7f82f9a98b97d1503c1e3f31c86061c15 (patch)
tree7e387db7a374aad1f0865147c0b3403e09c77ce3 /functions/architectures.sh
parent72a87fb70d26153bdfe06d0cdf42a199ff7ad68d (diff)
downloadvyos-live-build-2d9ab1f7f82f9a98b97d1503c1e3f31c86061c15.tar.gz
vyos-live-build-2d9ab1f7f82f9a98b97d1503c1e3f31c86061c15.zip
Test for executables: replace 'which' with more robust 'command -v'
Instances of: if [ $(which <command> ] have been replaced with: if command -v <command> >/dev/null which is considered to be more robust in a range of environments. scripts/build/chroot_archives: line 259: if [ "${LB_APT}" = "aptitude" ] && [ ! $(Chroot chroot "which aptitude") ] has been left untouched because the chroot might require a more complex command which would need more testing. manpages/Makefile: line 42: @if [ ! -x "$$(which po4a 2>/dev/null)" ]; \ has been left untouched because I am not sufficiently familiar with makefiles.
Diffstat (limited to 'functions/architectures.sh')
-rwxr-xr-xfunctions/architectures.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/functions/architectures.sh b/functions/architectures.sh
index aeb298eb3..bdad4cbc0 100755
--- a/functions/architectures.sh
+++ b/functions/architectures.sh
@@ -50,7 +50,7 @@ Check_architectures ()
Check_crossarchitectures ()
{
- if [ $(which dpkg) ]
+ if command -v dpkg >/dev/null
then
HOST="$(dpkg --print-architecture)"
else