summaryrefslogtreecommitdiff
path: root/functions/defaults.sh
diff options
context:
space:
mode:
authorjohnraff <github@rafflesnagoya.com>2020-03-12 14:37:21 +0900
committerLuca Boccassi <bluca@debian.org>2020-03-12 10:35:57 +0000
commit2d9ab1f7f82f9a98b97d1503c1e3f31c86061c15 (patch)
tree7e387db7a374aad1f0865147c0b3403e09c77ce3 /functions/defaults.sh
parent72a87fb70d26153bdfe06d0cdf42a199ff7ad68d (diff)
downloadvyos-live-build-2d9ab1f7f82f9a98b97d1503c1e3f31c86061c15.tar.gz
vyos-live-build-2d9ab1f7f82f9a98b97d1503c1e3f31c86061c15.zip
Test for executables: replace 'which' with more robust 'command -v'
Instances of: if [ $(which <command> ] have been replaced with: if command -v <command> >/dev/null which is considered to be more robust in a range of environments. scripts/build/chroot_archives: line 259: if [ "${LB_APT}" = "aptitude" ] && [ ! $(Chroot chroot "which aptitude") ] has been left untouched because the chroot might require a more complex command which would need more testing. manpages/Makefile: line 42: @if [ ! -x "$$(which po4a 2>/dev/null)" ]; \ has been left untouched because I am not sufficiently familiar with makefiles.
Diffstat (limited to 'functions/defaults.sh')
-rwxr-xr-xfunctions/defaults.sh6
1 files changed, 3 insertions, 3 deletions
diff --git a/functions/defaults.sh b/functions/defaults.sh
index 695195d9d..14dd5d269 100755
--- a/functions/defaults.sh
+++ b/functions/defaults.sh
@@ -14,7 +14,7 @@ New_configuration ()
## Runtime
# Image: Architecture
- if [ $(which dpkg) ]
+ if command -v dpkg >/dev/null
then
CURRENT_IMAGE_ARCHITECTURE="$(dpkg --print-architecture)"
else
@@ -94,7 +94,7 @@ Set_config_defaults ()
LB_SYSTEM="${LB_SYSTEM:-live}"
# Setting mode (currently: debian, progress-linux)
- if [ $(which lsb_release) ]
+ if command -v lsb_release >/dev/null
then
_DISTRIBUTOR="$(lsb_release -is | tr "[A-Z]" "[a-z]")"
@@ -802,7 +802,7 @@ Check_config_defaults ()
{
case "${LB_BINARY_FILESYSTEM}" in
ntfs)
- if [ ! $(which ntfs-3g) ]
+ if ! command -v ntfs-3g >/dev/null
then
Echo_error "Using ntfs as the binary filesystem is currently only supported if ntfs-3g is installed on the host system."