summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xscripts/build/binary_loopback_cfg2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f2e6488b5..e4b5b449f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ live-build (1:20171208) UNRELEASED; urgency=medium
* Restore i386/amd64 autodetection in grub after rename of
i386 kernel from -486 to -686. Closes: #884585
Thanks to Adrian Gibanel Lopez for the patch.
+ * Fix handling of multiple kernels in binary_loopback_cfg.
+ Closes: #884588 Thanks to Adrian Gibanel Lopez for the patch.
-- Raphaƫl Hertzog <hertzog@debian.org> Thu, 21 Dec 2017 14:14:04 +0100
diff --git a/scripts/build/binary_loopback_cfg b/scripts/build/binary_loopback_cfg
index 2e6787a72..ff487a40f 100755
--- a/scripts/build/binary_loopback_cfg
+++ b/scripts/build/binary_loopback_cfg
@@ -211,7 +211,7 @@ fi
_COUNT=0
for KERNEL in chroot/boot/vmlinuz-*; do
- _COUNT=$(( $COUNT + 1 ))
+ _COUNT=$(( $_COUNT + 1 ))
done
if [ $_COUNT -gt 1 ]; then