summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile6
-rw-r--r--debian/changelog8
-rw-r--r--docs/ChangeLog5
-rwxr-xr-xfunctions/common.sh2
-rwxr-xr-xhelpers/lh_clean159
-rw-r--r--manpages/lh_binary.de.12
-rw-r--r--manpages/lh_binary.en.12
-rw-r--r--manpages/lh_bootstrap.de.12
-rw-r--r--manpages/lh_bootstrap.en.12
-rw-r--r--manpages/lh_bootstrap_cdebootstrap.de.12
-rw-r--r--manpages/lh_bootstrap_cdebootstrap.en.12
-rw-r--r--manpages/lh_bootstrap_debootstrap.de.12
-rw-r--r--manpages/lh_bootstrap_debootstrap.en.12
-rw-r--r--manpages/lh_build.de.12
-rw-r--r--manpages/lh_build.en.12
-rw-r--r--manpages/lh_chroot.de.12
-rw-r--r--manpages/lh_chroot.en.12
-rw-r--r--manpages/lh_clean.de.12
-rw-r--r--manpages/lh_clean.en.12
-rw-r--r--manpages/lh_config.de.12
-rw-r--r--manpages/lh_config.en.12
-rw-r--r--manpages/lh_source.de.12
-rw-r--r--manpages/lh_source.en.12
-rw-r--r--manpages/lh_testroot.de.12
-rw-r--r--manpages/lh_testroot.en.12
-rw-r--r--manpages/live-helper.de.72
-rw-r--r--manpages/live-helper.en.72
27 files changed, 120 insertions, 104 deletions
diff --git a/Makefile b/Makefile
index 7fbda836c..5aeb27bf8 100644
--- a/Makefile
+++ b/Makefile
@@ -91,9 +91,9 @@ uninstall:
update:
set -e; for FILE in functions/*.sh examples/cron/*.sh manpages/*.de.* manpages/*.en.*; \
do \
- sed -i -e 's/2007\\-08\\-13/2007\\-08\\-20/' \
- -e 's/13.08.2007/20.08.2007/' \
- -e 's/1.0~a23/1.0~a24/' \
+ sed -i -e 's/2007\\-08\\-20/2007\\-08\\-27/' \
+ -e 's/20.08.2007/27.08.2007/' \
+ -e 's/1.0~a24/1.0~a25/' \
$$FILE; \
done
diff --git a/debian/changelog b/debian/changelog
index 41552dfa9..360beec74 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+live-helper (1.0~a24-1) unstable; urgency=medium
+
+ * New upstream release:
+ - lh_clean accepts more than one argument at the same time
+ (Closes: #439947).
+
+ -- Daniel Baumann <daniel@debian.org> Mon, 20 Aug 2007 00:00:00 +0200
+
live-helper (1.0~a23-1) unstable; urgency=medium
* New upstream release.
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 4f8a76962..fcc9335d1 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,8 @@
+2007-08-28 Daniel Baumann <daniel@debian.org>
+
+ * helpers/lh_clean:
+ - Accepting more than one parameter at the same time.
+
2007-08-14 Daniel Baumann <daniel@debian.org>
* helpers/*:
diff --git a/functions/common.sh b/functions/common.sh
index c7f8269d4..e56b80fc7 100755
--- a/functions/common.sh
+++ b/functions/common.sh
@@ -10,4 +10,4 @@
set -e
PROGRAM="`basename ${0}`"
-VERSION="1.0~a23"
+VERSION="1.0~a24"
diff --git a/helpers/lh_clean b/helpers/lh_clean
index 4c52ed24d..021100f91 100755
--- a/helpers/lh_clean
+++ b/helpers/lh_clean
@@ -35,81 +35,84 @@ Set_defaults
rm -f .lock
-case "${1}" in
- all)
- "${0}" chroot
- "${0}" binary
- "${0}" stage
- "${0}" source
-
- if [ -d chroot ]
- then
- mkdir -p .stage
- touch .stage/bootstrap
- fi
- ;;
-
- cache)
- ${LH_ROOT_COMMAND} rm -rf cache
- ;;
-
- chroot)
- Echo_message "Cleaning chroot"
- ${LH_ROOT_COMMAND} umount -f chroot/sys > /dev/null 2>&1 || true
- ${LH_ROOT_COMMAND} umount -f chroot/proc/sys/fs/binfmt_misc > /dev/null 2>&1 || true
- ${LH_ROOT_COMMAND} umount -f chroot/proc > /dev/null 2>&1 || true
- ${LH_ROOT_COMMAND} umount -f chroot/lib/init/rw > /dev/null 2>&1 || true
- ${LH_ROOT_COMMAND} umount -f chroot/dev/shm > /dev/null 2>&1 || true
- ${LH_ROOT_COMMAND} umount -f chroot/dev/pts > /dev/null 2>&1 || true
- ${LH_ROOT_COMMAND} umount -f chroot/dev > /dev/null 2>&1 || true
-
- ${LH_ROOT_COMMAND} rm -rf chroot chroot.tmp
-
- if [ "${PURGE}" != "true" ] && [ -d cache/stages_bootstrap ]
- then
- ${LH_ROOT_COMMAND} cp -a cache/stages_bootstrap chroot
- mkdir -p .stage
- touch .stage/bootstrap
- fi
-
- rm -f .stage/chroot*
- ;;
-
- binary)
- ${LH_ROOT_COMMAND} umount -f binary.tmp > /dev/null 2>&1 || true
- rm -rf binary.tmp binary.deb binary.udeb
- rm -f binary.iso
- rm -f binary.img
- rm -f binary*.tar.gz
- rm -f binary.sh
-
- rm -rf binary
- rm -rf tftpboot
-
- rm -f .stage/binary*
- ;;
-
- purge)
- PURGE="true" "${0}" all
- "${0}" cache
- ;;
-
- stage)
- rm -rf .stage
- ;;
-
- source)
- rm -f source.iso
- rm -f source.img
- rm -f source*.tar
- rm -f source*.tar.gz
-
- rm -rf source
-
- rm -f .stage/source*
- ;;
-
- *)
- "${0}" all
- ;;
-esac
+for ARGUMENT in ${@}
+do
+ case "${ARGUMENT}" in
+ all)
+ "${0}" chroot
+ "${0}" binary
+ "${0}" stage
+ "${0}" source
+
+ if [ -d chroot ]
+ then
+ mkdir -p .stage
+ touch .stage/bootstrap
+ fi
+ ;;
+
+ cache)
+ ${LH_ROOT_COMMAND} rm -rf cache
+ ;;
+
+ chroot)
+ Echo_message "Cleaning chroot"
+ ${LH_ROOT_COMMAND} umount -f chroot/sys > /dev/null 2>&1 || true
+ ${LH_ROOT_COMMAND} umount -f chroot/proc/sys/fs/binfmt_misc > /dev/null 2>&1 || true
+ ${LH_ROOT_COMMAND} umount -f chroot/proc > /dev/null 2>&1 || true
+ ${LH_ROOT_COMMAND} umount -f chroot/lib/init/rw > /dev/null 2>&1 || true
+ ${LH_ROOT_COMMAND} umount -f chroot/dev/shm > /dev/null 2>&1 || true
+ ${LH_ROOT_COMMAND} umount -f chroot/dev/pts > /dev/null 2>&1 || true
+ ${LH_ROOT_COMMAND} umount -f chroot/dev > /dev/null 2>&1 || true
+
+ ${LH_ROOT_COMMAND} rm -rf chroot chroot.tmp
+
+ if [ "${PURGE}" != "true" ] && [ -d cache/stages_bootstrap ]
+ then
+ ${LH_ROOT_COMMAND} cp -a cache/stages_bootstrap chroot
+ mkdir -p .stage
+ touch .stage/bootstrap
+ fi
+
+ rm -f .stage/chroot*
+ ;;
+
+ binary)
+ ${LH_ROOT_COMMAND} umount -f binary.tmp > /dev/null 2>&1 || true
+ rm -rf binary.tmp binary.deb binary.udeb
+ rm -f binary.iso
+ rm -f binary.img
+ rm -f binary*.tar.gz
+ rm -f binary.sh
+
+ rm -rf binary
+ rm -rf tftpboot
+
+ rm -f .stage/binary*
+ ;;
+
+ purge)
+ PURGE="true" "${0}" all
+ "${0}" cache
+ ;;
+
+ stage)
+ rm -rf .stage
+ ;;
+
+ source)
+ rm -f source.iso
+ rm -f source.img
+ rm -f source*.tar
+ rm -f source*.tar.gz
+
+ rm -rf source
+
+ rm -f .stage/source*
+ ;;
+
+ *)
+ "${0}" all
+ ;;
+ esac
+done
diff --git a/manpages/lh_binary.de.1 b/manpages/lh_binary.de.1
index 3100a88be..61013a673 100644
--- a/manpages/lh_binary.de.1
+++ b/manpages/lh_binary.de.1
@@ -1,4 +1,4 @@
-.TH LH_BINARY 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_BINARY 1 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
lh_binary \- Meta\-Helper f\[:u]r lh_binary_*
diff --git a/manpages/lh_binary.en.1 b/manpages/lh_binary.en.1
index 97fc3bd9e..b4f9b25cb 100644
--- a/manpages/lh_binary.en.1
+++ b/manpages/lh_binary.en.1
@@ -1,4 +1,4 @@
-.TH LH_BINARY 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_BINARY 1 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
lh_binary \- meta\-helper for lh_binary_*
diff --git a/manpages/lh_bootstrap.de.1 b/manpages/lh_bootstrap.de.1
index db538f53c..abbbfb48b 100644
--- a/manpages/lh_bootstrap.de.1
+++ b/manpages/lh_bootstrap.de.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP 1 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
lh_bootstrap \- Meta\-Helper f\[:u]r lh_bootstrap_*
diff --git a/manpages/lh_bootstrap.en.1 b/manpages/lh_bootstrap.en.1
index afaec2c28..ec6066ff0 100644
--- a/manpages/lh_bootstrap.en.1
+++ b/manpages/lh_bootstrap.en.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP 1 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
lh_bootstrap \- meta\-helper for lh_bootstrap_*
diff --git a/manpages/lh_bootstrap_cdebootstrap.de.1 b/manpages/lh_bootstrap_cdebootstrap.de.1
index e1c58052c..f31fc3a9f 100644
--- a/manpages/lh_bootstrap_cdebootstrap.de.1
+++ b/manpages/lh_bootstrap_cdebootstrap.de.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP_CDEBOOTSTRAP 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP_CDEBOOTSTRAP 1 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
lh_bootstrap_cdebootstrap \- erstellt ein Debian-System mit \fIcdebootstrap\fR(1)
diff --git a/manpages/lh_bootstrap_cdebootstrap.en.1 b/manpages/lh_bootstrap_cdebootstrap.en.1
index 23f48b43c..713285502 100644
--- a/manpages/lh_bootstrap_cdebootstrap.en.1
+++ b/manpages/lh_bootstrap_cdebootstrap.en.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP_CDEBOOTSTRAP 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP_CDEBOOTSTRAP 1 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
lh_bootstrap_cdebootstrap \- bootstrap a Debian system with \fIcdebootstrap\fR(1)
diff --git a/manpages/lh_bootstrap_debootstrap.de.1 b/manpages/lh_bootstrap_debootstrap.de.1
index 7a453cb86..f37a73e32 100644
--- a/manpages/lh_bootstrap_debootstrap.de.1
+++ b/manpages/lh_bootstrap_debootstrap.de.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP_DEBOOTSTRAP 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP_DEBOOTSTRAP 1 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
lh_bootstrap_debootstrap \- erstellt ein Debian-System mit \fIdebootstrap\fR(8)
diff --git a/manpages/lh_bootstrap_debootstrap.en.1 b/manpages/lh_bootstrap_debootstrap.en.1
index e5b0e2909..5443503ee 100644
--- a/manpages/lh_bootstrap_debootstrap.en.1
+++ b/manpages/lh_bootstrap_debootstrap.en.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP_DEBOOTSTRAP 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP_DEBOOTSTRAP 1 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
lh_bootstrap_debootstrap \- bootstrap a Debian system with \fIdebootstrap\fR(8)
diff --git a/manpages/lh_build.de.1 b/manpages/lh_build.de.1
index 4895e1a17..73213c5ba 100644
--- a/manpages/lh_build.de.1
+++ b/manpages/lh_build.de.1
@@ -1,4 +1,4 @@
-.TH LH_BUILD 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_BUILD 1 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
lh_build \- erstellen eines Live-Systemes
diff --git a/manpages/lh_build.en.1 b/manpages/lh_build.en.1
index 09fd64222..5b9e6f12d 100644
--- a/manpages/lh_build.en.1
+++ b/manpages/lh_build.en.1
@@ -1,4 +1,4 @@
-.TH LH_BUILD 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_BUILD 1 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
lh_build \- building a live system
diff --git a/manpages/lh_chroot.de.1 b/manpages/lh_chroot.de.1
index a4b3cbb96..5aa8aaa42 100644
--- a/manpages/lh_chroot.de.1
+++ b/manpages/lh_chroot.de.1
@@ -1,4 +1,4 @@
-.TH LH_CHROOT 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_CHROOT 1 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
lh_chroot \- Meta\-Helper f\[:u]r lh_chroot_*
diff --git a/manpages/lh_chroot.en.1 b/manpages/lh_chroot.en.1
index 7139ac019..f587ca0d0 100644
--- a/manpages/lh_chroot.en.1
+++ b/manpages/lh_chroot.en.1
@@ -1,4 +1,4 @@
-.TH LH_CHROOT 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_CHROOT 1 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
lh_chroot \- meta\-helper for lh_chroot_*
diff --git a/manpages/lh_clean.de.1 b/manpages/lh_clean.de.1
index 06df50584..8c39bf43c 100644
--- a/manpages/lh_clean.de.1
+++ b/manpages/lh_clean.de.1
@@ -1,4 +1,4 @@
-.TH LH_CLEAN 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_CLEAN 1 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
lh_clean \- r\[:a]umt das Build-Verzeichnis auf
diff --git a/manpages/lh_clean.en.1 b/manpages/lh_clean.en.1
index 2684ef7ec..64bd8bbda 100644
--- a/manpages/lh_clean.en.1
+++ b/manpages/lh_clean.en.1
@@ -1,4 +1,4 @@
-.TH LH_CLEAN 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_CLEAN 1 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
lh_clean \- clean up system build directories
diff --git a/manpages/lh_config.de.1 b/manpages/lh_config.de.1
index 126f48bf6..0c3e1bc41 100644
--- a/manpages/lh_config.de.1
+++ b/manpages/lh_config.de.1
@@ -1,4 +1,4 @@
-.TH LH_CONFIG 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_CONFIG 1 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
lh_config \- erstellt live-helper(7) Konfiguration
diff --git a/manpages/lh_config.en.1 b/manpages/lh_config.en.1
index 1825ff1a6..c5129f03b 100644
--- a/manpages/lh_config.en.1
+++ b/manpages/lh_config.en.1
@@ -1,4 +1,4 @@
-.TH LH_CONFIG 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_CONFIG 1 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
lh_config \- create configuration for live-helper(7)
diff --git a/manpages/lh_source.de.1 b/manpages/lh_source.de.1
index c819d3f86..18aabbc97 100644
--- a/manpages/lh_source.de.1
+++ b/manpages/lh_source.de.1
@@ -1,4 +1,4 @@
-.TH LH_SOURCE 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_SOURCE 1 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
lh_source \- Meta\-Helper f\[:u]r lh_source_*
diff --git a/manpages/lh_source.en.1 b/manpages/lh_source.en.1
index e39090da8..e5693a676 100644
--- a/manpages/lh_source.en.1
+++ b/manpages/lh_source.en.1
@@ -1,4 +1,4 @@
-.TH LH_SOURCE 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_SOURCE 1 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
lh_source \- meta\-helper for lh_source_*
diff --git a/manpages/lh_testroot.de.1 b/manpages/lh_testroot.de.1
index 570195114..0f35ac1af 100644
--- a/manpages/lh_testroot.de.1
+++ b/manpages/lh_testroot.de.1
@@ -1,4 +1,4 @@
-.TH LH_TESTROOT 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_TESTROOT 1 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
lh_testroot \- stellt sicher dass das System als root gebaut wird
diff --git a/manpages/lh_testroot.en.1 b/manpages/lh_testroot.en.1
index 8ce9ec69c..6f415da73 100644
--- a/manpages/lh_testroot.en.1
+++ b/manpages/lh_testroot.en.1
@@ -1,4 +1,4 @@
-.TH LH_TESTROOT 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_TESTROOT 1 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
lh_testroot \- ensure that a system is built as root
diff --git a/manpages/live-helper.de.7 b/manpages/live-helper.de.7
index 08f17a60d..afadf2abf 100644
--- a/manpages/live-helper.de.7
+++ b/manpages/live-helper.de.7
@@ -1,4 +1,4 @@
-.TH LIVE\-HELPER 7 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LIVE\-HELPER 7 "20.08.2007" "1.0~a24" "live\-helper"
.SH NAME
live\-helper \- Debian Live Helper-Programme
diff --git a/manpages/live-helper.en.7 b/manpages/live-helper.en.7
index bdb22bf44..097c296a5 100644
--- a/manpages/live-helper.en.7
+++ b/manpages/live-helper.en.7
@@ -1,4 +1,4 @@
-.TH LIVE\-HELPER 7 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LIVE\-HELPER 7 "2007\-08\-20" "1.0~a24" "live\-helper"
.SH NAME
live\-helper \- Debian Live helper programs