summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--VERSION2
-rwxr-xr-xfunctions/common.sh2
3 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index bdbaa539d..cbb247853 100644
--- a/Makefile
+++ b/Makefile
@@ -40,7 +40,7 @@ build:
install:
# Installing shared data
mkdir -p $(DESTDIR)/usr/share/live/build
- cp -r cgi data examples functions scripts includes package-lists templates $(DESTDIR)/usr/share/live/build
+ cp -r cgi data examples functions scripts includes package-lists templates VERSION $(DESTDIR)/usr/share/live/build
cp -r share/* $(DESTDIR)/usr/share/live/build
# Installing executables
diff --git a/VERSION b/VERSION
index f5d60d54a..fa688b253 100644
--- a/VERSION
+++ b/VERSION
@@ -1 +1 @@
-3.0~a28
+3.0~a28-1
diff --git a/functions/common.sh b/functions/common.sh
index b410cfcd5..327020abc 100755
--- a/functions/common.sh
+++ b/functions/common.sh
@@ -9,7 +9,7 @@
PROGRAM="live-build"
-VERSION="3.0~a28-1"
+VERSION="$(cat ${LB_BASE}VERSION)"
CONFIG_VERSION="$(echo ${VERSION} | awk -F- '{ print $1 }')"
PATH="${PWD}/auto/scripts:${PATH}"