summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 9 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index b7ef8a90e..50d5bb7be 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,11 +8,16 @@ clean:
dh_testdir
dh_testroot
+ # Cleaning message catalogs
+ $(MAKE) -C po clean
+
dh_clean
build:
+ # Updating message catalogs
+ $(MAKE) -C po update-po
-install:
+install: build
dh_testdir
dh_testroot
dh_clean -k
@@ -21,6 +26,9 @@ install:
# Installing package
$(MAKE) install DESTDIR=$(CURDIR)/debian/live-helper
+ # Installing message catalogs
+ $(MAKE) -C po install DESTDIR=$(CURDIR)/debian/live-helper
+
install -D -m 0644 debian/default debian/live-helper/etc/default/live-helper
# Preparing alternatives