summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules5
2 files changed, 7 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 660d02bac..0e18b1e62 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -41,6 +41,8 @@ live-build (1:20161128) UNRELEASED; urgency=medium
* Use a grub theme that integrates reasonably well with the current
background picture.
* Default for LB_UNION_FILESYSTEM is now "overlay" just like in live-boot.
+ * Update the way we generate the version of live-build that is displayed by
+ lb --version.
[ Kristian Klausen ]
* Include ext{3,4} journal size when calculating image size. Closes: #801712
diff --git a/debian/rules b/debian/rules
index 2d2e62735..92cbff285 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,16 @@
#!/usr/bin/make -f
+include /usr/share/dpkg/pkg-info.mk
+
%:
dh $@
override_dh_auto_install:
dh_auto_install -- DESTDIR=debian/live-build
+ # Update VERSION file
+ echo $(DEB_VERSION) >debian/live-build/usr/share/live/build/VERSION
+
# Removing unused files
rm -f debian/live-build/usr/share/doc/live-build/COPYING