#!/usr/bin/make -f

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

upstream:
	cd .. && git clone git://git.debian.org/git/users/daniel/live-helper.git || true
	rm -rf ../live-helper/.git

build:

clean:
	dh_testdir
	dh_testroot

	dh_clean

install: build
	dh_testdir
	dh_testroot
	dh_clean -k
	dh_installdirs

	# Installing package
	$(MAKE) install DESTDIR=$(CURDIR)/debian/live-helper

	install -D -m 0644 debian/changelog.live-package debian/live-helper/usr/share/doc/live-helper/changelog.Debian.live-package

	install -D -m 0644 debian/default debian/live-helper/etc/default/live-helper

	# Preparing alternatives
	mv debian/live-helper/usr/share/live-helper/includes debian/live-helper/usr/share/live-helper/includes.debian
	mv debian/live-helper/usr/share/live-helper/templates debian/live-helper/usr/share/live-helper/templates.debian

	# Removing double files
	rm -f debian/live-helper/usr/share/doc/live-helper/COPYING
	rm -f debian/live-helper/usr/share/doc/live-helper/ChangeLog
	mv debian/live-helper/usr/share/doc/live-helper/ChangeLog.live-package debian/live-helper/usr/share/doc/live-helper/changelog.live-package

	# Installing bug control
	install -D -m 0755 debian/bug/script debian/live-helper/usr/share/bug/live-helper

binary-arch: build install

binary-indep: build install
	dh_testdir
	dh_testroot
	dh_installchangelogs docs/ChangeLog
	dh_installdocs
	dh_install
	dh_installlogrotate
	dh_installcron
	dh_installman
	dh_compress
	dh_fixperms
	dh_installdeb
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install