summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2008-08-07 11:15:28 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2008-08-07 11:15:28 +0000
commit71eaa3a2b0097e441a97c6392f060f9407746f3a (patch)
tree846823aa8d81b45f7c34ed24406146d0cecfea0e /debian/rules
parent99ec352ff311e6e964d6fb2160001e4b2b18b738 (diff)
downloadvyos-strongswan-71eaa3a2b0097e441a97c6392f060f9407746f3a.tar.gz
vyos-strongswan-71eaa3a2b0097e441a97c6392f060f9407746f3a.zip
- Fix 2 bugs.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 16 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index ec5318cb5..d2d7702f9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,11 +10,7 @@ export DH_OPTIONS
# this is a security-critical package, set all the options we can
export DEB_BUILD_HARDENING=1
-configure: configure-stamp
-configure-stamp: patch
- dh_testdir
- # Add here commands to configure the package.
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+CONFIGUREARGS := --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--libexecdir=/usr/lib \
--enable-http --enable-ldap \
--enable-nonblocking --enable-thread \
@@ -22,12 +18,26 @@ configure-stamp: patch
--with-default-pkcs11=/usr/lib/opensc-pkcs11.so \
--enable-xml \
--enable-p2p --enable-manager \
- --enable-padlock --enable-openssl
+ --enable-openssl
# Could enable --enable-nat-transport, but this is actually insecure,
# so don't!
# And for --enable-eap-sim we would need the library, which we don't
# have right now.
+DEB_BUILD_ARCH_CPU ?=$(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
+
+#the padlock plugin only makes sense on i386
+ifeq ($(DEB_BUILD_ARCH_CPU),i386)
+ CONFIGUREARGS += --enable-padlock
+endif
+
+
+configure: configure-stamp
+configure-stamp: patch
+ dh_testdir
+ # Add here commands to configure the package.
+ ./configure $(CONFIGUREARGS)
+
touch configure-stamp
patch: