summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@corsac.net>2012-06-28 22:19:02 +0200
committerYves-Alexis Perez <corsac@corsac.net>2012-06-28 22:19:02 +0200
commit1a366650b5a42b95bbcd4843e49cd153f766bd2c (patch)
treed98f3bcd3f2c0affcbe4e09ba42ab8fa900c9e88 /debian/rules
parenta36b47e9b1e8d7992ffdb2deaf44b5b28803c625 (diff)
downloadvyos-strongswan-1a366650b5a42b95bbcd4843e49cd153f766bd2c.tar.gz
vyos-strongswan-1a366650b5a42b95bbcd4843e49cd153f766bd2c.zip
inconditionnally enable network-manager.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 2 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index 052355f7c..35eae316c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,8 @@ CONFIGUREARGS := --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--enable-sql --enable-integrity-test \
--enable-ha --enable-dhcp --enable-farp \
--enable-led \
- --enable-test-vectors --enable-nat-transport
+ --enable-test-vectors --enable-nat-transport \
+ --enable-nm
# --with-user=strongswan --with-group=nogroup \
# --enable-kernel-pfkey --enable-kernel-klips \
# And for --enable-eap-sim we would need the library, which we don't
@@ -48,14 +49,6 @@ ifeq ($(DEB_BUILD_ARCH_CPU),i386)
CONFIGUREARGS += --enable-padlock
endif
-# And only enable network-manager building if the libraries are present
-# (they will be when the build-deps are fulfilled, but this makes it easier
-# to do backports where the network-manager libs can not be installed, and
-# thus to just ignore build-deps).
-ifeq ($(shell test -d /usr/include/libnm-glib/ && echo yes),yes)
- CONFIGUREARGS += --enable-nm
-endif
-
build: build-stamp
build-stamp:
dh_testdir
@@ -99,8 +92,6 @@ install: build-stamp
ifeq ($(DEB_BUILD_ARCH_CPU),i386)
install $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/libstrongswan-padlock.so* $(CURDIR)/debian/libstrongswan/usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/
endif
- # and special handling for network-manager files - only install when built
- install $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/libstrongswan-nm.so* $(CURDIR)/debian/strongswan-nm/usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/
# and additional files not covered by upstream makefile...
install --mode=0600 $(CURDIR)/debian/ipsec.secrets.proto $(CURDIR)/debian/strongswan-starter/etc/ipsec.secrets