summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@debian.org>2013-05-06 12:43:24 +0200
committerYves-Alexis Perez <corsac@debian.org>2013-05-06 13:13:54 +0200
commit1aa454e3cd0b2951babb5dfe0f26a2fbdcc9bc2f (patch)
treea85f69ee50d82ee3e3d1d11105d3fbed89ad26a5 /debian/rules
parent92065a2b61c05896e70cfeb341961d12bec4ec82 (diff)
downloadvyos-strongswan-1aa454e3cd0b2951babb5dfe0f26a2fbdcc9bc2f.tar.gz
vyos-strongswan-1aa454e3cd0b2951babb5dfe0f26a2fbdcc9bc2f.zip
Only enable RdRand on i386 and amd64
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 6 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index c76816404..fcb4eac56 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,7 +18,6 @@ CONFIGUREARGS := --libdir=/usr/lib --libexecdir=/usr/lib \
--enable-test-vectors \
--enable-xauth-eap --enable-xauth-pam \
--enable-attr-sql \
- --enable-rdrand \
--disable-blowfish --disable-des # BSD-Young license
#--with-user=strongswan --with-group=nogroup
# --enable-kernel-pfkey --enable-kernel-klips \
@@ -29,10 +28,14 @@ CONFIGUREARGS := --libdir=/usr/lib --libexecdir=/usr/lib \
# sends these Cisco options.
# the padlock plugin only makes sense on i386
-# but it actually doesn't do much, so maybe we don't need it
+# RdRand only makes sense on i386 and amd64
DEB_BUILD_ARCH_CPU ?=$(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
ifeq ($(DEB_BUILD_ARCH_CPU),i386)
- CONFIGUREARGS += --enable-padlock
+ CONFIGUREARGS += --enable-padlock --enable-rdrand
+endif
+
+ifeq ($(DEB_BUILD_ARCH_CPU),amd64)
+ CONFIGUREARGS += --enable-rdrand
endif
ifeq ($(DEB_BUILD_ARCH_OS),linux)