summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2008-09-01 07:05:58 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2008-09-01 07:05:58 +0000
commite855a6d4aacd39908acdeec6d6bafcf4e9c3aa12 (patch)
treebe3f062190c78dc1bea893c554610a21165b980b /debian/rules
parentc195a7a5c9826db4eaa98943dbe08165b5ef3745 (diff)
downloadvyos-strongswan-e855a6d4aacd39908acdeec6d6bafcf4e9c3aa12.tar.gz
vyos-strongswan-e855a6d4aacd39908acdeec6d6bafcf4e9c3aa12.zip
- Tweaked configure options for a smaller package.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 9 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 23d64ab3f..90ccca852 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,9 +16,10 @@ CONFIGUREARGS := --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--enable-nonblocking --enable-thread \
--enable-smartcard --enable-cisco-quirks \
--with-default-pkcs11=/usr/lib/opensc-pkcs11.so \
- --enable-xml \
- --enable-mediation --enable-manager \
- --enable-openssl
+ --enable-mediation \
+ --enable-openssl \
+ --disable-aes --disable-des --disable-fips-prf --disable-gmp \
+ --disable-md5 --disable-sha1 --disable-sha2
# Could enable --enable-nat-transport, but this is actually insecure,
# so don't!
# And for --enable-eap-sim we would need the library, which we don't
@@ -26,10 +27,11 @@ CONFIGUREARGS := --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
DEB_BUILD_ARCH_CPU ?=$(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
-#the padlock plugin only makes sense on i386
-ifeq ($(DEB_BUILD_ARCH_CPU),i386)
- CONFIGUREARGS += --enable-padlock
-endif
+# the padlock plugin only makes sense on i386
+# but it actually doesn't do much, so no need to enable it
+#ifeq ($(DEB_BUILD_ARCH_CPU),i386)
+# CONFIGUREARGS += --enable-padlock
+#endif
configure: configure-stamp