summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2007-11-02 22:56:07 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2007-11-02 22:56:07 +0000
commit5c33d896a0f1bb98625f51119caf34294ba7fa60 (patch)
treecf102ebd0396f693e2dadc9bd2a1e2937949ab8c /debian/rules
parentb8b1a4e04d0928c8b468b75561ffa07a63ae2a8c (diff)
downloadvyos-strongswan-5c33d896a0f1bb98625f51119caf34294ba7fa60.tar.gz
vyos-strongswan-5c33d896a0f1bb98625f51119caf34294ba7fa60.zip
- Make the Makefile work...
- Cleanup slightly, although configure is still run twice (and I don't know why).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 7 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 091944925..0b77fac3d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -61,10 +61,9 @@ clean: unpatch
dh_clean
install-strongswan: DH_OPTIONS=-a
-install-strongswan: build
+install-strongswan: build-stamp
dh_testdir
dh_testroot
- dh_clean -k
dh_installdirs
# Add here commands to install the package into debian/tmp.
@@ -74,7 +73,7 @@ install-strongswan: build
echo >> $(CURDIR)/debian/strongswan/etc/ipsec.conf
echo "include /var/lib/strongswan/ipsec.conf.inc" >> $(CURDIR)/debian/strongswan/etc/ipsec.secrets
# and to enable both IKEv1 and IKEv2 by default
- sed "s/^\w+#\w*plutostart=(yes|no)\w*$/\tplutostart=yes/;s/^\w+#\w*charonstart=(yes|no)\w*$/\tcharonstart=yes/" < $(CURDIR)/debian/strongswan/etc/ipsec.conf > $(CURDIR)/debian/strongswan/etc/ipsec.conf.tmp
+ sed -r 's/^[ \t]+# *plutostart=(yes|no) */\tplutostart=yes/;s/^[ \t]+# *charonstart=(yes|no) */\tcharonstart=yes/' < $(CURDIR)/debian/strongswan/etc/ipsec.conf > $(CURDIR)/debian/strongswan/etc/ipsec.conf.tmp
mv $(CURDIR)/debian/strongswan/etc/ipsec.conf.tmp $(CURDIR)/debian/strongswan/etc/ipsec.conf
# this is handled by update-rc.d
@@ -93,7 +92,7 @@ install-strongswan: build
rm $$f.old; \
fi; \
done )
-
+
# the logcheck ignore files
install -D --mode=0600 $(CURDIR)/debian/logcheck.ignore.paranoid $(CURDIR)/debian/strongswan/etc/logcheck/ignore.d.paranoid/strongswan
install -D --mode=0600 $(CURDIR)/debian/logcheck.ignore.server $(CURDIR)/debian/strongswan/etc/logcheck/ignore.d.server/strongswan
@@ -124,7 +123,6 @@ binary-common:
dh_strip
dh_compress
dh_fixperms -X etc/ipsec.conf -X etc/ipsec.secrets -X etc/ipsec.d
-
dh_makeshlibs
dh_installdeb
dh_shlibdeps
@@ -134,15 +132,15 @@ binary-common:
# Build architecture-independent files here.
binary-indep:
- $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
+ $(MAKE) -f debian/rules binary-common DH_OPTIONS=-i
# Build architecture-dependent files here.
binary-arch: install-strongswan
- $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
+ $(MAKE) -f debian/rules binary-common DH_OPTIONS=-a
# Any other binary targets build just one binary package at a time.
-binary-%: build install
+binary-%: build-stamp install-strongswan
make -f debian/rules binary-common DH_OPTIONS=-p$*
-
+
binary: binary-indep binary-arch
.PHONY: clean binary-indep binary-arch