summaryrefslogtreecommitdiff
path: root/debian/strongswan-modules-source.rules
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2006-05-22 06:41:59 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2006-05-22 06:41:59 +0000
commitc6d4f7459c3436c6e629a6b1fcd7f73bcaeca790 (patch)
treeceeffc0a0897427a5c42733da1d9d46992f303f7 /debian/strongswan-modules-source.rules
parent4769e2f961d2930ffcc6cfa5b1561548e4ea552c (diff)
downloadvyos-strongswan-c6d4f7459c3436c6e629a6b1fcd7f73bcaeca790.tar.gz
vyos-strongswan-c6d4f7459c3436c6e629a6b1fcd7f73bcaeca790.zip
- s/openswan/strongswan/g
- s/Openswan/strongSwan/g But basically manually. Is certainly incomplete right now.
Diffstat (limited to 'debian/strongswan-modules-source.rules')
-rwxr-xr-xdebian/strongswan-modules-source.rules150
1 files changed, 150 insertions, 0 deletions
diff --git a/debian/strongswan-modules-source.rules b/debian/strongswan-modules-source.rules
new file mode 100755
index 000000000..f31746de1
--- /dev/null
+++ b/debian/strongswan-modules-source.rules
@@ -0,0 +1,150 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatability version to use.
+export DH_COMPAT=4
+
+VERS = $(shell sed -ne '1s/.*(\(.*\)).*/\1/p' debian/changelog)
+
+# KSRC is the location of the kernel source. This is the default value,
+# when make-kpkg is used it will supply to real value
+KSRC = /usr/src/linux
+
+# KDREV is the package-revision, as given to make-kpkg by the user.
+# Just put a simply default value in here which we use when we test
+# the packagebuilding without make-kpkg
+KDREV = "Custom.1.00"
+
+# Separate the epoch from the normal revision number in KDREV
+# for use with dh_gencontrol
+KDREV_EPOCH = $(shell echo $(KDREV) | sed -ne '1s/\([^:]*:\)\?\(.*\)/\1/p')
+KDREV_REV = $(shell echo $(KDREV) | sed -ne '1s/\([^:]*:\)\?\(.*\)/\2/p')
+
+# Now we need to get the kernel-version somehow
+KVERS=`sed -n -e '/UTS_RELEASE/s/^[^"]*"\([^"]*\)".*$$/\1/p' $(KSRC)/include/linux/version.h`
+
+SED_SCRIPT=s!\$$KVERS!$(KVERS)!g; \
+ s!\$$KSRC!$(KSRC)!; \
+ s!\$$KEMAIL!$(KEMAIL)!; \
+ s!\$$KMAINT!$(KMAINT)!; \
+ s!\$$KDREV!$(KDREV)!; \
+ s!\$$DEBDATE!$(shell date +"%a, %d %b %Y %H:%M:%S %z")!
+
+ifeq ($(DEB_DEST),)
+DEB_DEST=$(KSRC)/..
+endif
+
+# Clear root command if already root
+ifeq ($(shell id -u),0)
+ROOT_CMD=
+endif
+
+# this primarily sets ARCH, we may be able to do that in another way
+# but it also defines IPSECVERSION, which is needed below
+include Makefile.inc
+
+debian/control: debian/control.in
+ sed -e "$(SED_SCRIPT)" debian/control.in > $@
+
+.PHONY: debian/control
+
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+build: debian/control configure-stamp build-stamp
+build-stamp:
+ dh_testdir
+
+ $(MAKE) module KERNELSRC=${KSRC} OPENSWANSRCDIR=$(CURDIR)
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ $(MAKE) modclean KERNELSRC=${KSRC} OPENSWANSRCDIR=$(CURDIR)
+
+ dh_clean
+
+ rm -f debian/control
+
+MODDESTDIR=$(CURDIR)/debian/openswan-modules-$(KVERS)/lib/modules/$(KVERS)/kernel/net/ipsec
+install:
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ mkdir -p $(MODDESTDIR)
+ if [ -d modobj ]; then \
+ cp modobj/ipsec.o $(MODDESTDIR); \
+ cp modobj/ipsec_alg_*.o $(MODDESTDIR); \
+ else \
+ cp modobj26/ipsec.ko $(MODDESTDIR); \
+ fi
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+# dh_installdebconf
+ dh_installdocs
+ dh_installexamples
+ dh_installmenu
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+ dh_installmodules
+ dh_installcron
+ dh_installman
+ dh_installinfo
+# dh_undocumented
+ dh_installchangelogs
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_makeshlibs
+ dh_installdeb
+# dh_perl
+ dh_shlibdeps
+ dh_gencontrol -- -v$(KDREV_EPOCH)$(VERS)+$(KDREV_REV)
+ dh_md5sums
+ dh_builddeb --destdir=$(DEB_DEST)
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
+
+binary-modules: binary
+
+
+kdist_image:
+ $(ROOT_CMD) $(MAKE) -f debian/rules binary-modules
+ $(ROOT_CMD) $(MAKE) -f debian/rules clean
+kdist_clean: debian/control clean
+kdist:
+ $(ROOT_CMD) $(MAKE) -f debian/rules binary-modules
+kdist_configure: configure-stamp
+
+
+.PHONY: binary-modules kdist_image
+