summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRomain Francoise <rfrancoise@debian.org>2014-07-25 23:15:34 +0200
committerRomain Francoise <rfrancoise@debian.org>2014-07-25 23:55:55 +0200
commitd5dc988a10f44a08f0b85e85d23abbd84c06a927 (patch)
treed8ceacb101a49d6a1c98e3607fdb401fba82bcfb /debian
parent9057ca8363bf16444c3f80b2f0c5222565ad216e (diff)
downloadvyos-strongswan-d5dc988a10f44a08f0b85e85d23abbd84c06a927.tar.gz
vyos-strongswan-d5dc988a10f44a08f0b85e85d23abbd84c06a927.zip
Initial systemd integration
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog14
-rw-r--r--debian/control4
-rw-r--r--debian/patches/03_systemd-service.patch15
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/strongswan-starter.install1
6 files changed, 34 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index a505fbe11..adbc5ddb8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+strongswan (5.2.0-2) UNRELEASED; urgency=medium
+
+ * Add systemd integration:
+ + Install upstream systemd service file in strongswan-starter.
+ + Alias strongswan.service to ipsec.service to match the sysv init script.
+ + Drop After=syslog.target, as syslog is socket-activated nowadays.
+ + Add ExecReload for reload action, since the starter script has one.
+ + On linux-any, add build-dep on systemd to ensure that the pkg-config
+ metadata file can be found.
+ + Add build-dep on dh-systemd, and use systemd dh addon.
+ * Remove debian/patches/03_include-stdint.patch.
+
+ -- Romain Francoise <rfrancoise@debian.org> Fri, 25 Jul 2014 22:51:04 +0200
+
strongswan (5.2.0-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/control b/debian/control
index 5b8d400d9..ddf690548 100644
--- a/debian/control
+++ b/debian/control
@@ -11,11 +11,11 @@ Vcs-Git: git://anonscm.debian.org/pkg-swan/strongswan.git
Build-Depends: debhelper (>= 9), dpkg-dev (>= 1.16.2), libtool, libgmp3-dev,
libssl-dev (>= 0.9.8), libcurl4-openssl-dev | libcurl3-dev | libcurl2-dev,
libldap2-dev, libpam0g-dev, libkrb5-dev, bison, flex, bzip2, po-debconf,
- libfcgi-dev, clearsilver-dev,
+ libfcgi-dev, clearsilver-dev, libgcrypt20-dev | libgcrypt11-dev,
libxml2-dev, libsqlite3-dev, network-manager-dev (>= 0.7) [linux-any],
libnm-glib-vpn-dev (>= 0.7) [linux-any], libnm-util-dev (>= 0.7) [linux-any],
gperf, libcap-dev [linux-any], dh-autoreconf, pkg-config,
- libgcrypt20-dev | libgcrypt11-dev
+ systemd [linux-any], dh-systemd (>= 1.5)
Homepage: http://www.strongswan.org
Package: strongswan
diff --git a/debian/patches/03_systemd-service.patch b/debian/patches/03_systemd-service.patch
new file mode 100644
index 000000000..bcf581295
--- /dev/null
+++ b/debian/patches/03_systemd-service.patch
@@ -0,0 +1,15 @@
+--- a/init/systemd/strongswan.service.in
++++ b/init/systemd/strongswan.service.in
+@@ -1,10 +1,11 @@
+ [Unit]
+ Description=strongSwan IPsec
+-After=syslog.target
+
+ [Service]
+ ExecStart=@SBINDIR@/@IPSEC_SCRIPT@ start --nofork
++ExecReload=@SBINDIR@/@IPSEC_SCRIPT@ reload
+ StandardOutput=syslog
+
+ [Install]
+ WantedBy=multi-user.target
++Alias=ipsec.service
diff --git a/debian/patches/series b/debian/patches/series
index 27732685c..7d9c29e3d 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
01_fix-manpages.patch
02_disable-libtls-tests.patch
+03_systemd-service.patch
diff --git a/debian/rules b/debian/rules
index 51ab054e7..8af4d3d30 100755
--- a/debian/rules
+++ b/debian/rules
@@ -196,4 +196,4 @@ override_dh_installlogcheck:
dh_installlogcheck --name strongswan
%:
- dh $@ --parallel --with autoreconf
+ dh $@ --parallel --with autoreconf,systemd
diff --git a/debian/strongswan-starter.install b/debian/strongswan-starter.install
index 5d765eeb5..ee8c8eca7 100644
--- a/debian/strongswan-starter.install
+++ b/debian/strongswan-starter.install
@@ -10,6 +10,7 @@ usr/share/man/man8/ipsec.8
usr/share/man/man5/ipsec.conf.5
usr/share/man/man5/ipsec.secrets.5
usr/share/man/man5/strongswan.conf.5
+lib/systemd/system/strongswan.service
#updown
usr/lib/ipsec/plugins/libstrongswan-updown.so
usr/share/strongswan/templates/config/plugins/updown.conf