summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2010-08-16 21:11:57 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2010-08-16 21:11:57 +0000
commitcd9213eb46ccfebf043397d94f9c532e01f88c45 (patch)
treebd61aa9f6f76c882089aed0cf53c4ccd80600cbd /debian
parentfd143c38bd56f2db9a3df0db9bae030f078c6bee (diff)
downloadvyos-strongswan-cd9213eb46ccfebf043397d94f9c532e01f88c45.tar.gz
vyos-strongswan-cd9213eb46ccfebf043397d94f9c532e01f88c45.zip
Fix lintian warnings and errors.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
-rw-r--r--debian/strongswan-starter.lintian-overrides1
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d12d7b2df..c9014e8fc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -108,6 +108,10 @@ endif
# this is handled by update-rc.d
rm -rf $(CURDIR)/debian/strongswan-starter/etc/rc?.d
+ # delete var/lock/subsys and var/run to satisfy lintian
+ rm -rf $(CURDIR)/debian/openswan/var/lock
+ rm -rf $(CURDIR)/debian/openswan/var/run
+
dh_installdocs -pstrongswan -n
# change the paths in the installed doc files (but only in regular
# files, not in links to the outside of the build tree !)
@@ -147,6 +151,7 @@ binary-common:
dh_strip --dbg-package=strongswan-dbg
dh_compress
dh_fixperms -X etc/ipsec.secrets -X etc/ipsec.d
+ dh_lintian
dh_makeshlibs
dh_installdeb
dh_shlibdeps
diff --git a/debian/strongswan-starter.lintian-overrides b/debian/strongswan-starter.lintian-overrides
index 7432ef5c8..02731f348 100644
--- a/debian/strongswan-starter.lintian-overrides
+++ b/debian/strongswan-starter.lintian-overrides
@@ -2,4 +2,3 @@
strongswan-starter: non-standard-dir-perm etc/ipsec.d/private/ 0700 != 0755
strongswan-starter: non-standard-file-perm etc/ipsec.secrets 0600 != 0644
strongswan-starter: non-standard-dir-perm var/lib/openswan/ 0700 != 0755
-strongswan-starter: dir-or-file-in-var-lock var/lock/subsys/