summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@debian.org>2014-07-11 07:23:31 +0200
committerYves-Alexis Perez <corsac@debian.org>2014-07-11 07:23:31 +0200
commit81c63b0eed39432878f78727f60a1e7499645199 (patch)
tree82387d8fecd1c20788fd8bd784a9b0bde091fb6b /src/Makefile.am
parentc5ebfc7b9c16551fe825dc1d79c3f7e2f096f6c9 (diff)
downloadvyos-strongswan-81c63b0eed39432878f78727f60a1e7499645199.tar.gz
vyos-strongswan-81c63b0eed39432878f78727f60a1e7499645199.zip
Imported Upstream version 5.2.0
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 93da4893f..95c68d0c8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -72,8 +72,16 @@ if USE_UPDOWN
SUBDIRS += _updown _updown_espmark
endif
-if USE_TOOLS
- SUBDIRS += scepclient pki
+if USE_SCEPCLIENT
+ SUBDIRS += scepclient
+endif
+
+if USE_PKI
+ SUBDIRS += pki
+endif
+
+if USE_SWANCTL
+ SUBDIRS += swanctl
endif
if USE_CONFTEST
@@ -112,6 +120,10 @@ if USE_CMD
SUBDIRS += charon-cmd
endif
+if USE_SVC
+ SUBDIRS += charon-svc
+endif
+
if USE_LIBPTTLS
SUBDIRS += pt-tls-client
endif
@@ -119,3 +131,7 @@ endif
if USE_INTEGRITY_TEST
SUBDIRS += checksum
endif
+
+if USE_AIKGEN
+ SUBDIRS += aikgen
+endif