summaryrefslogtreecommitdiff
path: root/src/charon/Makefile.am
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@debian.org>2013-01-02 14:18:20 +0100
committerYves-Alexis Perez <corsac@debian.org>2013-01-02 14:18:20 +0100
commitc1343b3278cdf99533b7902744d15969f9d6fdc1 (patch)
treed5ed3dc5677a59260ec41cd39bb284d3e94c91b3 /src/charon/Makefile.am
parentb34738ed08c2227300d554b139e2495ca5da97d6 (diff)
downloadvyos-strongswan-c1343b3278cdf99533b7902744d15969f9d6fdc1.tar.gz
vyos-strongswan-c1343b3278cdf99533b7902744d15969f9d6fdc1.zip
Imported Upstream version 5.0.1
Diffstat (limited to 'src/charon/Makefile.am')
-rw-r--r--src/charon/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/charon/Makefile.am b/src/charon/Makefile.am
index 6481947f1..0ca15cb10 100644
--- a/src/charon/Makefile.am
+++ b/src/charon/Makefile.am
@@ -3,6 +3,8 @@ ipsec_PROGRAMS = charon
charon_SOURCES = \
charon.c
+charon.o : $(top_builddir)/config.status
+
INCLUDES = \
-I$(top_srcdir)/src/libstrongswan \
-I$(top_srcdir)/src/libhydra \
@@ -10,7 +12,8 @@ INCLUDES = \
AM_CFLAGS = \
-DIPSEC_DIR=\"${ipsecdir}\" \
- -DIPSEC_PIDDIR=\"${piddir}\"
+ -DIPSEC_PIDDIR=\"${piddir}\" \
+ -DPLUGINS=\""${charon_plugins}\""
charon_LDADD = \
$(top_builddir)/src/libstrongswan/libstrongswan.la \