summaryrefslogtreecommitdiff
path: root/src/checksum/Makefile.am
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@debian.org>2014-07-11 07:23:31 +0200
committerYves-Alexis Perez <corsac@debian.org>2014-07-11 07:23:31 +0200
commit81c63b0eed39432878f78727f60a1e7499645199 (patch)
tree82387d8fecd1c20788fd8bd784a9b0bde091fb6b /src/checksum/Makefile.am
parentc5ebfc7b9c16551fe825dc1d79c3f7e2f096f6c9 (diff)
downloadvyos-strongswan-81c63b0eed39432878f78727f60a1e7499645199.tar.gz
vyos-strongswan-81c63b0eed39432878f78727f60a1e7499645199.zip
Imported Upstream version 5.2.0
Diffstat (limited to 'src/checksum/Makefile.am')
-rw-r--r--src/checksum/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/checksum/Makefile.am b/src/checksum/Makefile.am
index 82bbadcf1..821c51747 100644
--- a/src/checksum/Makefile.am
+++ b/src/checksum/Makefile.am
@@ -22,7 +22,7 @@ AM_CPPFLAGS = \
-DPLUGINDIR=\"${DESTDIR}${plugindir}\"
AM_CFLAGS = \
- -rdynamic
+ $(PLUGIN_CFLAGS)
# we keep track of build dependencies in deps and use libs to store the paths
# to the installed libraries. for executables we use the built files directly
@@ -99,11 +99,18 @@ if USE_CMD
exes += $(DESTDIR)$(sbindir)/charon-cmd
endif
-if USE_TOOLS
+if USE_SCEPCLIENT
exes += $(DESTDIR)$(ipsecdir)/scepclient
+endif
+
+if USE_PKI
exes += $(DESTDIR)$(bindir)/pki
endif
+if USE_SWANCTL
+ exes += $(DESTDIR)$(sbindir)/swanctl
+endif
+
if USE_ATTR_SQL
exes += $(DESTDIR)$(ipsecdir)/pool
endif