summaryrefslogtreecommitdiff
path: root/src/conftest/Makefile.am
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@debian.org>2013-08-25 15:37:26 +0200
committerYves-Alexis Perez <corsac@debian.org>2013-08-25 15:37:26 +0200
commit6b99c8d9cff7b3e8ae8f3204b99e7ea40f791349 (patch)
tree009fc492961e13860d2a4bc2de8caf2bbe2975e7 /src/conftest/Makefile.am
parentc83921a2b566aa9d55d8ccc7258f04fca6292ee6 (diff)
downloadvyos-strongswan-6b99c8d9cff7b3e8ae8f3204b99e7ea40f791349.tar.gz
vyos-strongswan-6b99c8d9cff7b3e8ae8f3204b99e7ea40f791349.zip
Imported Upstream version 5.1.0
Diffstat (limited to 'src/conftest/Makefile.am')
-rw-r--r--src/conftest/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/conftest/Makefile.am b/src/conftest/Makefile.am
index 64a2cc6d3..2aafc7a6f 100644
--- a/src/conftest/Makefile.am
+++ b/src/conftest/Makefile.am
@@ -1,6 +1,9 @@
ipsec_PROGRAMS = conftest
-AM_CFLAGS = -rdynamic \
+AM_CPPFLAGS = -rdynamic \
+ -I$(top_srcdir)/src/libstrongswan \
+ -I$(top_srcdir)/src/libhydra \
+ -I$(top_srcdir)/src/libcharon \
-DPLUGINS=\""${charon_plugins}\""
conftest_SOURCES = conftest.c conftest.h config.c config.h actions.c actions.h \
@@ -13,11 +16,6 @@ conftest_SOURCES = conftest.c conftest.h config.c config.h actions.c actions.h \
hooks/set_ike_request.c hooks/set_reserved.c hooks/set_ike_initiator.c \
hooks/log_ts.c hooks/rebuild_auth.c hooks/reset_seq.c
-INCLUDES = \
- -I$(top_srcdir)/src/libstrongswan \
- -I$(top_srcdir)/src/libhydra \
- -I$(top_srcdir)/src/libcharon
-
conftest_LDADD = \
$(top_builddir)/src/libstrongswan/libstrongswan.la \
$(top_builddir)/src/libhydra/libhydra.la \