summaryrefslogtreecommitdiff
path: root/src/libcharon/Makefile.am
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@debian.org>2013-08-25 15:37:26 +0200
committerYves-Alexis Perez <corsac@debian.org>2013-08-25 15:37:26 +0200
commit6b99c8d9cff7b3e8ae8f3204b99e7ea40f791349 (patch)
tree009fc492961e13860d2a4bc2de8caf2bbe2975e7 /src/libcharon/Makefile.am
parentc83921a2b566aa9d55d8ccc7258f04fca6292ee6 (diff)
downloadvyos-strongswan-6b99c8d9cff7b3e8ae8f3204b99e7ea40f791349.tar.gz
vyos-strongswan-6b99c8d9cff7b3e8ae8f3204b99e7ea40f791349.zip
Imported Upstream version 5.1.0
Diffstat (limited to 'src/libcharon/Makefile.am')
-rw-r--r--src/libcharon/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/src/libcharon/Makefile.am b/src/libcharon/Makefile.am
index f0736c5ca..10d0b04cb 100644
--- a/src/libcharon/Makefile.am
+++ b/src/libcharon/Makefile.am
@@ -128,13 +128,11 @@ endif
daemon.lo : $(top_builddir)/config.status
-INCLUDES = \
+AM_CPPFLAGS = \
-I${linux_headers} \
-I$(top_srcdir)/src/libstrongswan \
-I$(top_srcdir)/src/libhydra \
- -I$(top_srcdir)/src/libcharon
-
-AM_CFLAGS = \
+ -I$(top_srcdir)/src/libcharon \
-DIPSEC_DIR=\"${ipsecdir}\" \
-DIPSEC_PIDDIR=\"${piddir}\"
@@ -457,6 +455,13 @@ if MONOLITHIC
endif
endif
+if USE_OSX_ATTR
+ SUBDIRS += plugins/osx_attr
+if MONOLITHIC
+ libcharon_la_LIBADD += plugins/osx_attr/libstrongswan-osx-attr.la
+endif
+endif
+
if USE_ANDROID_DNS
SUBDIRS += plugins/android_dns
if MONOLITHIC
@@ -485,6 +490,13 @@ if MONOLITHIC
endif
endif
+if USE_KERNEL_LIBIPSEC
+ SUBDIRS += plugins/kernel_libipsec
+if MONOLITHIC
+ libcharon_la_LIBADD += plugins/kernel_libipsec/libstrongswan-kernel-libipsec.la
+endif
+endif
+
if USE_WHITELIST
SUBDIRS += plugins/whitelist
if MONOLITHIC