summaryrefslogtreecommitdiff
path: root/src/libcharon/plugins/ipseckey/Makefile.am
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@debian.org>2013-04-26 14:57:47 +0200
committerYves-Alexis Perez <corsac@debian.org>2013-04-26 14:57:47 +0200
commite8f63514e9b56f6a2f977a56438d59ccab45bdca (patch)
treea0b54b11d647db27fa018214d2bf675dd350d466 /src/libcharon/plugins/ipseckey/Makefile.am
parent196d9f518fd657d6560bfe3b05885d47ccd6bbd5 (diff)
parent10e5fb2b9b2f27c83b3e5a1d048b158d5cf42a43 (diff)
downloadvyos-strongswan-e8f63514e9b56f6a2f977a56438d59ccab45bdca.tar.gz
vyos-strongswan-e8f63514e9b56f6a2f977a56438d59ccab45bdca.zip
Merge tag 'upstream/5.0.3'
Upstream version 5.0.3
Diffstat (limited to 'src/libcharon/plugins/ipseckey/Makefile.am')
-rw-r--r--src/libcharon/plugins/ipseckey/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/libcharon/plugins/ipseckey/Makefile.am b/src/libcharon/plugins/ipseckey/Makefile.am
new file mode 100644
index 000000000..0614017a0
--- /dev/null
+++ b/src/libcharon/plugins/ipseckey/Makefile.am
@@ -0,0 +1,18 @@
+
+INCLUDES = \
+ -I$(top_srcdir)/src/libstrongswan \
+ -I$(top_srcdir)/src/libhydra \
+ -I$(top_srcdir)/src/libcharon
+
+if MONOLITHIC
+noinst_LTLIBRARIES = libstrongswan-ipseckey.la
+else
+plugin_LTLIBRARIES = libstrongswan-ipseckey.la
+endif
+
+libstrongswan_ipseckey_la_SOURCES = \
+ ipseckey_plugin.h ipseckey_plugin.c \
+ ipseckey_cred.h ipseckey_cred.c \
+ ipseckey.h ipseckey.c
+
+libstrongswan_ipseckey_la_LDFLAGS = -module -avoid-version