summaryrefslogtreecommitdiff
path: root/src/libstrongswan/plugins/mgf1/Makefile.am
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@debian.org>2016-10-20 16:18:38 +0200
committerYves-Alexis Perez <corsac@debian.org>2016-10-20 16:18:38 +0200
commit88f22dbc6ddb53ac5b40db1d317548b0408718c9 (patch)
tree923fc438bad68d2583b27c12036a6883d73bd5f9 /src/libstrongswan/plugins/mgf1/Makefile.am
parent3bba989a734d13493279f8c1266176ebb1f670bd (diff)
parent25663e04c3ab01ef8dc9f906608282319cfea2db (diff)
downloadvyos-strongswan-88f22dbc6ddb53ac5b40db1d317548b0408718c9.tar.gz
vyos-strongswan-88f22dbc6ddb53ac5b40db1d317548b0408718c9.zip
Merge tag 'upstream/5.5.1'
Upstream version 5.5.1
Diffstat (limited to 'src/libstrongswan/plugins/mgf1/Makefile.am')
-rw-r--r--src/libstrongswan/plugins/mgf1/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/libstrongswan/plugins/mgf1/Makefile.am b/src/libstrongswan/plugins/mgf1/Makefile.am
new file mode 100644
index 000000000..8df227f9f
--- /dev/null
+++ b/src/libstrongswan/plugins/mgf1/Makefile.am
@@ -0,0 +1,17 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan
+
+AM_CFLAGS = \
+ $(PLUGIN_CFLAGS)
+
+if MONOLITHIC
+noinst_LTLIBRARIES = libstrongswan-mgf1.la
+else
+plugin_LTLIBRARIES = libstrongswan-mgf1.la
+endif
+
+libstrongswan_mgf1_la_SOURCES = \
+ mgf1_plugin.h mgf1_plugin.c \
+ mgf1_xof.h mgf1_xof.c
+
+libstrongswan_mgf1_la_LDFLAGS = -module -avoid-version