summaryrefslogtreecommitdiff
path: root/src/libstrongswan/plugins/test_vectors/Makefile.am
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2009-06-23 11:25:24 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2009-06-23 11:25:24 +0000
commit41787e147279ff0695e9d759487266a60b80867b (patch)
tree8f28566c8fd7106c80d2536d2df540dbb4499cc5 /src/libstrongswan/plugins/test_vectors/Makefile.am
parentc3e7f611ea8273c6b3909cb006ade4903a74aad0 (diff)
downloadvyos-strongswan-41787e147279ff0695e9d759487266a60b80867b.tar.gz
vyos-strongswan-41787e147279ff0695e9d759487266a60b80867b.zip
[svn-upgrade] Integrating new upstream version, strongswan (4.3.2)
Diffstat (limited to 'src/libstrongswan/plugins/test_vectors/Makefile.am')
-rw-r--r--src/libstrongswan/plugins/test_vectors/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/libstrongswan/plugins/test_vectors/Makefile.am b/src/libstrongswan/plugins/test_vectors/Makefile.am
new file mode 100644
index 000000000..27d17c084
--- /dev/null
+++ b/src/libstrongswan/plugins/test_vectors/Makefile.am
@@ -0,0 +1,33 @@
+
+INCLUDES = -I$(top_srcdir)/src/libstrongswan
+
+AM_CFLAGS = -rdynamic
+
+plugin_LTLIBRARIES = libstrongswan-test-vectors.la
+
+libstrongswan_test_vectors_la_SOURCES = \
+ test_vectors_plugin.h test_vectors_plugin.c test_vectors.h \
+ test_vectors/3des_cbc.c \
+ test_vectors/aes_cbc.c \
+ test_vectors/aes_xcbc.c \
+ test_vectors/blowfish.c \
+ test_vectors/camellia_cbc.c \
+ test_vectors/cast.c \
+ test_vectors/des.c \
+ test_vectors/idea.c \
+ test_vectors/null.c \
+ test_vectors/rc5.c \
+ test_vectors/serpent_cbc.c \
+ test_vectors/twofish_cbc.c \
+ test_vectors/md2.c \
+ test_vectors/md4.c \
+ test_vectors/md5.c \
+ test_vectors/md5_hmac.c \
+ test_vectors/sha1.c \
+ test_vectors/sha1_hmac.c \
+ test_vectors/sha2.c \
+ test_vectors/sha2_hmac.c \
+ test_vectors/fips_prf.c \
+ test_vectors/rng.c
+libstrongswan_test_vectors_la_LDFLAGS = -module
+