summaryrefslogtreecommitdiff
path: root/src/manager/Makefile.am
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2008-07-09 21:02:41 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2008-07-09 21:02:41 +0000
commitdb67c87db3c9089ea8d2e14f617bf3d9e2af261f (patch)
tree665c0caea83d34c11c1517c4c57137bb58cba6fb /src/manager/Makefile.am
parent1c088a8b6237ec67f63c23f97a0f2dc4e99af869 (diff)
downloadvyos-strongswan-db67c87db3c9089ea8d2e14f617bf3d9e2af261f.tar.gz
vyos-strongswan-db67c87db3c9089ea8d2e14f617bf3d9e2af261f.zip
[svn-upgrade] Integrating new upstream version, strongswan (4.2.4)
Diffstat (limited to 'src/manager/Makefile.am')
-rw-r--r--src/manager/Makefile.am60
1 files changed, 27 insertions, 33 deletions
diff --git a/src/manager/Makefile.am b/src/manager/Makefile.am
index 7f77d1dba..6c50f1563 100644
--- a/src/manager/Makefile.am
+++ b/src/manager/Makefile.am
@@ -1,52 +1,46 @@
-ipsec_PROGRAMS = manager.fcgi
+managerdir = ${ipsecdir}/manager
+
+manager_PROGRAMS = manager.fcgi
manager_fcgi_SOURCES = \
-main.c manager.c manager.h gateway.h gateway.c database.h database.c \
+main.c manager.c manager.h gateway.h gateway.c storage.h storage.c xml.h xml.c \
controller/auth_controller.c controller/auth_controller.h \
controller/ikesa_controller.c controller/ikesa_controller.h \
controller/control_controller.c controller/control_controller.h \
controller/config_controller.c controller/config_controller.h \
controller/gateway_controller.c controller/gateway_controller.h
-manager_fcgi_LDADD = $(top_builddir)/src/manager/libappserv.la -lsqlite3
-
-
-
-lib_LTLIBRARIES = libappserv.la
-
-libappserv_la_SOURCES = \
-lib/context.h lib/dispatcher.c lib/request.h lib/session.h \
-lib/controller.h lib/dispatcher.h lib/request.c lib/session.c \
-lib/xml.h lib/xml.c
-
-libappserv_la_LIBADD = $(top_builddir)/src/libstrongswan/libstrongswan.la -lfcgi -lpthread -lneo_cgi -lneo_cs -lneo_utl ${xml_LIBS}
-
-INCLUDES = -I$(top_srcdir)/src/libstrongswan -I$(top_srcdir)/src/manager/lib -I/usr/include/ClearSilver ${xml_CFLAGS}
-AM_CFLAGS = -rdynamic -DIPSECDIR=\"${ipsecdir}\" -DIPSEC_PIDDIR=\"${piddir}\"
+manager_fcgi_LDADD = $(top_builddir)/src/libfast/libfast.la ${xml_LIBS}
-ipsec_DATA = manager.db
+INCLUDES = -I$(top_srcdir)/src/libstrongswan -I$(top_srcdir)/src/libfast ${xml_CFLAGS}
+AM_CFLAGS = -rdynamic \
+ -DSTRONGSWAN_CONF=\"${strongswan_conf}\" \
+ -DIPSECDIR=\"${ipsecdir}\" \
+ -DIPSEC_PIDDIR=\"${piddir}\" \
+ -DIPSEC_PLUGINDIR=\"${plugindir}\"\
+ -DPLUGINS=\""${libstrongswan_plugins}\""
# Don't forget to add templates to EXTRA_DIST !!! How to automate?
-ipsec_templatesdir = ${ipsecdir}/templates
-ipsec_templates_DATA = templates/header.cs templates/footer.cs templates/error.cs
+manager_templatesdir = ${managerdir}/templates
+manager_templates_DATA = templates/header.cs templates/footer.cs templates/error.cs
-ipsec_templates_authdir = ${ipsec_templatesdir}/auth
-ipsec_templates_auth_DATA = templates/auth/login.cs
+manager_templates_authdir = ${manager_templatesdir}/auth
+manager_templates_auth_DATA = templates/auth/login.cs
-ipsec_templates_gatewaydir = ${ipsec_templatesdir}/gateway
-ipsec_templates_gateway_DATA = templates/gateway/list.cs
+manager_templates_gatewaydir = ${manager_templatesdir}/gateway
+manager_templates_gateway_DATA = templates/gateway/list.cs
-ipsec_templates_ikesadir = ${ipsec_templatesdir}/ikesa
-ipsec_templates_ikesa_DATA = templates/ikesa/list.cs
+manager_templates_ikesadir = ${manager_templatesdir}/ikesa
+manager_templates_ikesa_DATA = templates/ikesa/list.cs
-ipsec_templates_controldir = ${ipsec_templatesdir}/control
-ipsec_templates_control_DATA = templates/control/result.cs
+manager_templates_controldir = ${manager_templatesdir}/control
+manager_templates_control_DATA = templates/control/result.cs
-ipsec_templates_configdir = ${ipsec_templatesdir}/config
-ipsec_templates_config_DATA = templates/config/list.cs
+manager_templates_configdir = ${manager_templatesdir}/config
+manager_templates_config_DATA = templates/config/list.cs
-ipsec_templates_staticdir = ${ipsec_templatesdir}/static
-ipsec_templates_static_DATA = templates/static/style.css templates/static/script.js templates/static/jquery.js \
+manager_templates_staticdir = ${manager_templatesdir}/static
+manager_templates_static_DATA = templates/static/style.css templates/static/script.js templates/static/jquery.js \
templates/static/pipe.png templates/static/pipe-good.png templates/static/pipe-bad.png \
templates/static/pipe-thin.png templates/static/pipe-thin-left.png templates/static/pipe-thin-right.png \
templates/static/pipe-thin-green.png templates/static/pipe-thin-left-green.png templates/static/pipe-thin-right-green.png \
@@ -54,7 +48,7 @@ templates/static/gateway-left.png templates/static/client-left.png templates/sta
templates/static/router.png templates/static/gateway-right.png templates/static/client-right.png \
templates/static/close.png templates/static/initiate.png
-EXTRA_DIST = manager.db templates/header.cs templates/footer.cs templates/error.cs \
+EXTRA_DIST = templates/header.cs templates/footer.cs templates/error.cs \
templates/auth/login.cs templates/gateway/list.cs templates/ikesa/list.cs \
templates/config/list.cs templates/control/result.cs \
templates/static/style.css templates/static/script.js templates/static/jquery.js \