summaryrefslogtreecommitdiff
path: root/src/medsrv/Makefile.am
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2008-07-09 21:02:41 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2008-07-09 21:02:41 +0000
commitdb67c87db3c9089ea8d2e14f617bf3d9e2af261f (patch)
tree665c0caea83d34c11c1517c4c57137bb58cba6fb /src/medsrv/Makefile.am
parent1c088a8b6237ec67f63c23f97a0f2dc4e99af869 (diff)
downloadvyos-strongswan-db67c87db3c9089ea8d2e14f617bf3d9e2af261f.tar.gz
vyos-strongswan-db67c87db3c9089ea8d2e14f617bf3d9e2af261f.zip
[svn-upgrade] Integrating new upstream version, strongswan (4.2.4)
Diffstat (limited to 'src/medsrv/Makefile.am')
-rw-r--r--src/medsrv/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/medsrv/Makefile.am b/src/medsrv/Makefile.am
new file mode 100644
index 000000000..8da1cfcc4
--- /dev/null
+++ b/src/medsrv/Makefile.am
@@ -0,0 +1,42 @@
+medsrvdir = ${ipsecdir}/medsrv
+
+medsrv_PROGRAMS = medsrv.fcgi
+
+medsrv_fcgi_SOURCES = user.h user.c \
+main.c filter/auth_filter.c filter/auth_filter.h \
+controller/user_controller.c controller/user_controller.h \
+controller/peer_controller.c controller/peer_controller.h
+
+medsrv_fcgi_LDADD = $(top_builddir)/src/libfast/libfast.la
+
+INCLUDES = -I$(top_srcdir)/src/libstrongswan -I$(top_srcdir)/src/libfast
+AM_CFLAGS = -rdynamic \
+ -DSTRONGSWAN_CONF=\"${strongswan_conf}\" \
+ -DIPSECDIR=\"${ipsecdir}\" \
+ -DIPSEC_PIDDIR=\"${piddir}\" \
+ -DIPSEC_PLUGINDIR=\"${plugindir}\"\
+ -DPLUGINS=\""${libstrongswan_plugins}\""
+
+# Don't forget to add templates to EXTRA_DIST !!! How to automate?
+medsrv_templatesdir = ${medsrvdir}/templates
+medsrv_templates_DATA = templates/header.cs templates/footer.cs
+
+medsrv_templates_userdir = ${medsrv_templatesdir}/user
+medsrv_templates_user_DATA = templates/user/add.cs templates/user/edit.cs \
+templates/user/login.cs templates/user/help.cs
+
+medsrv_templates_peerdir = ${medsrv_templatesdir}/peer
+medsrv_templates_peer_DATA = templates/peer/add.cs templates/peer/edit.cs \
+templates/peer/list.cs
+
+medsrv_templates_staticdir = ${medsrv_templatesdir}/static
+medsrv_templates_static_DATA = templates/header.cs templates/footer.cs \
+templates/static/style.css templates/static/strongswan.png \
+templates/static/favicon.ico templates/static/mootools.js templates/static/script.js
+
+EXTRA_DIST = templates/header.cs templates/footer.cs \
+templates/static/style.css templates/static/strongswan.png \
+templates/static/favicon.ico templates/static/mootools.js templates/static/script.js \
+templates/peer/add.cs templates/peer/edit.cs templates/peer/list.cs \
+templates/user/login.cs templates/user/add.cs templates/user/edit.cs \
+templates/user/help.cs