summaryrefslogtreecommitdiff
path: root/src/pluto/Makefile.am
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2008-07-09 21:02:41 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2008-07-09 21:02:41 +0000
commitdb67c87db3c9089ea8d2e14f617bf3d9e2af261f (patch)
tree665c0caea83d34c11c1517c4c57137bb58cba6fb /src/pluto/Makefile.am
parent1c088a8b6237ec67f63c23f97a0f2dc4e99af869 (diff)
downloadvyos-strongswan-db67c87db3c9089ea8d2e14f617bf3d9e2af261f.tar.gz
vyos-strongswan-db67c87db3c9089ea8d2e14f617bf3d9e2af261f.zip
[svn-upgrade] Integrating new upstream version, strongswan (4.2.4)
Diffstat (limited to 'src/pluto/Makefile.am')
-rw-r--r--src/pluto/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/pluto/Makefile.am b/src/pluto/Makefile.am
index 69902ad8f..156b81018 100644
--- a/src/pluto/Makefile.am
+++ b/src/pluto/Makefile.am
@@ -123,12 +123,19 @@ if USE_NAT_TRANSPORT
endif
# This compile option activates dynamic URL fetching using libcurl
-if USE_LIBCURL
+if USE_CURL
pluto_LDADD += -lcurl
+ AM_CFLAGS += -DLIBCURL
endif
# This compile option activates dynamic LDAP CRL fetching
-if USE_LIBLDAP
+if USE_LDAP
pluto_LDADD += -lldap -llber
+ AM_CFLAGS += -DLIBLDAP
+endif
+
+# This compile option activates smartcard support
+if USE_SMARTCARD
+ AM_CFLAGS += -DSMARTCARD
endif