summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in55
1 files changed, 53 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 54ff358d1..b0405130e 100644
--- a/configure.in
+++ b/configure.in
@@ -16,7 +16,7 @@ dnl ===========================
dnl initialize & set some vars
dnl ===========================
-AC_INIT(strongSwan,4.2.9)
+AC_INIT(strongSwan,4.2.12)
AM_INIT_AUTOMAKE(tar-ustar)
AC_C_BIGENDIAN
AC_SUBST(confdir, '${sysconfdir}')
@@ -185,6 +185,14 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [md4],
+ AS_HELP_STRING([--enable-md4],[enable MD4 software implementation plugin (default is NO).]),
+ [if test x$enableval = xyes; then
+ md4=true
+ fi]
+)
+
+AC_ARG_ENABLE(
[md5],
AS_HELP_STRING([--disable-md5],[disable own MD5 software implementation plugin. (default is NO).]),
[if test x$enableval = xyes; then
@@ -379,7 +387,7 @@ AC_ARG_ENABLE(
AC_ARG_ENABLE(
[lock-profiler],
- AS_HELP_STRING([--enable-lock-profiling],[enable lock/mutex profiling code (default is NO).]),
+ AS_HELP_STRING([--enable-lock-profiler],[enable lock/mutex profiling code (default is NO).]),
[if test x$enableval = xyes; then
lock_profiler=true
fi]
@@ -450,6 +458,14 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [eap-mschapv2],
+ AS_HELP_STRING([--enable-eap-mschapv2],[build MS-CHAPv2 authenication module for EAP (default is NO).]),
+ [if test x$enableval = xyes; then
+ eap_mschapv2=true
+ fi]
+)
+
+AC_ARG_ENABLE(
[kernel-netlink],
AS_HELP_STRING([--disable-kernel-netlink],[disable the netlink kernel interface. (default is NO).]),
[if test x$enableval = xyes; then
@@ -570,6 +586,17 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [threads],
+ AS_HELP_STRING([--disable-threads],[disable the use of threads in pluto. Charon always uses threads. (default is NO).]),
+ [if test x$enableval = xyes; then
+ threads=true
+ else
+ threads=false
+ fi],
+ threads=true
+)
+
+AC_ARG_ENABLE(
[charon],
AS_HELP_STRING([--disable-charon],[disable the IKEv2 keying daemon charon. (default is NO).]),
[if test x$enableval = xyes; then
@@ -697,6 +724,22 @@ AC_HAVE_LIBRARY(dl)
AC_CHECK_FUNCS(backtrace)
AC_CHECK_FUNCS(dladdr)
+AC_MSG_CHECKING([for gcc atomic operations])
+AC_TRY_RUN(
+[
+ int main() {
+ volatile int ref = 1;
+ __sync_fetch_and_add (&ref, 1);
+ __sync_sub_and_fetch (&ref, 1);
+ /* Make sure test fails if operations are not supported */
+ __sync_val_compare_and_swap(&ref, 1, 0);
+ return ref;
+ }
+],
+[AC_MSG_RESULT([yes]); AC_DEFINE(HAVE_GCC_ATOMIC_OPERATIONS)],
+[AC_MSG_RESULT([no])],
+[AC_MSG_RESULT([no])])
+
if test x$gmp = xtrue; then
AC_HAVE_LIBRARY([gmp],[LIBS="$LIBS"],[AC_MSG_ERROR([GNU Multi Precision library gmp not found])])
AC_MSG_CHECKING([gmp.h version >= 4.1.4])
@@ -821,6 +864,9 @@ fi
if test x$sha2 = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" sha2"
fi
+if test x$md4 = xtrue; then
+ libstrongswan_plugins=${libstrongswan_plugins}" md4"
+fi
if test x$md5 = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" md5"
fi
@@ -873,6 +919,7 @@ AM_CONDITIONAL(USE_CURL, test x$curl = xtrue)
AM_CONDITIONAL(USE_LDAP, test x$ldap = xtrue)
AM_CONDITIONAL(USE_AES, test x$aes = xtrue)
AM_CONDITIONAL(USE_DES, test x$des = xtrue)
+AM_CONDITIONAL(USE_MD4, test x$md4 = xtrue)
AM_CONDITIONAL(USE_MD5, test x$md5 = xtrue)
AM_CONDITIONAL(USE_SHA1, test x$sha1 = xtrue)
AM_CONDITIONAL(USE_SHA2, test x$sha2 = xtrue)
@@ -907,6 +954,7 @@ AM_CONDITIONAL(USE_EAP_IDENTITY, test x$eap_identity = xtrue)
AM_CONDITIONAL(USE_EAP_MD5, test x$eap_md5 = xtrue)
AM_CONDITIONAL(USE_EAP_GTC, test x$eap_gtc = xtrue)
AM_CONDITIONAL(USE_EAP_AKA, test x$eap_aka = xtrue)
+AM_CONDITIONAL(USE_EAP_MSCHAPV2, test x$eap_mschapv2 = xtrue)
AM_CONDITIONAL(USE_KERNEL_NETLINK, test x$kernel_netlink = xtrue)
AM_CONDITIONAL(USE_KERNEL_PFKEY, test x$kernel_pfkey = xtrue)
AM_CONDITIONAL(USE_KERNEL_KLIPS, test x$kernel_klips = xtrue)
@@ -928,6 +976,7 @@ AM_CONDITIONAL(USE_INTEGRITY_TEST, test x$integrity_test = xtrue)
AM_CONDITIONAL(USE_SELF_TEST, test x$self_test = xtrue)
AM_CONDITIONAL(USE_CAPABILITIES, test x$capabilities = xlibcap)
AM_CONDITIONAL(USE_PLUTO, test x$pluto = xtrue)
+AM_CONDITIONAL(USE_THREADS, test x$threads = xtrue)
AM_CONDITIONAL(USE_CHARON, test x$charon = xtrue)
AM_CONDITIONAL(USE_TOOLS, test x$tools = xtrue)
AM_CONDITIONAL(USE_LIBSTRONGSWAN, test x$charon = xtrue -o x$tools = xtrue)
@@ -955,6 +1004,7 @@ AC_OUTPUT(
src/libstrongswan/Makefile
src/libstrongswan/plugins/aes/Makefile
src/libstrongswan/plugins/des/Makefile
+ src/libstrongswan/plugins/md4/Makefile
src/libstrongswan/plugins/md5/Makefile
src/libstrongswan/plugins/sha1/Makefile
src/libstrongswan/plugins/sha2/Makefile
@@ -984,6 +1034,7 @@ AC_OUTPUT(
src/charon/plugins/eap_gtc/Makefile
src/charon/plugins/eap_sim/Makefile
src/charon/plugins/eap_sim_file/Makefile
+ src/charon/plugins/eap_mschapv2/Makefile
src/charon/plugins/kernel_netlink/Makefile
src/charon/plugins/kernel_pfkey/Makefile
src/charon/plugins/kernel_klips/Makefile