summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in200
1 files changed, 167 insertions, 33 deletions
diff --git a/configure.in b/configure.in
index 0bfb8287b..9a9796e81 100644
--- a/configure.in
+++ b/configure.in
@@ -16,7 +16,7 @@ dnl ===========================
dnl initialize & set some vars
dnl ===========================
-AC_INIT(strongSwan,4.5.2)
+AC_INIT(strongSwan,4.6.4)
AM_INIT_AUTOMAKE(tar-ustar)
AC_CONFIG_MACRO_DIR([m4/config])
PKG_PROG_PKG_CONFIG
@@ -34,7 +34,9 @@ ARG_WITH_SUBST([strongswan-conf], [${sysconfdir}/strongswan.conf], [set the s
ARG_WITH_SUBST([resolv-conf], [${sysconfdir}/resolv.conf], [set the file to use in DNS handler plugin])
ARG_WITH_SUBST([piddir], [/var/run], [set path for PID and UNIX socket files])
ARG_WITH_SUBST([ipsecdir], [${libexecdir%/}/ipsec], [set installation path for ipsec tools])
-ARG_WITH_SUBST([plugindir], [${ipsecdir%/}/plugins], [set the installation path of plugins])
+ARG_WITH_SUBST([ipseclibdir], [${libdir%/}/ipsec], [set installation path for ipsec libraries])
+ARG_WITH_SUBST([plugindir], [${ipseclibdir%/}/plugins], [set the installation path of plugins])
+ARG_WITH_SUBST([imcvdir], [${ipseclibdir%/}/imcvs], [set the installation path of IMC and IMV dynamic librariers])
ARG_WITH_SUBST([nm-ca-dir], [/usr/share/ca-certificates], [directory the NM plugin uses to look up trusted root certificates])
ARG_WITH_SUBST([linux-headers], [\${top_srcdir}/src/include], [set directory of linux header files to use])
ARG_WITH_SUBST([routing-table], [220], [set routing table to use for IPsec routes])
@@ -90,10 +92,12 @@ ARG_DISBL_SET([revocation], [disable X509 CRL/OCSP revocation check plugin.]
ARG_DISBL_SET([constraints], [disable advanced X509 constraint checking plugin.])
ARG_DISBL_SET([pubkey], [disable RAW public key support plugin.])
ARG_DISBL_SET([pkcs1], [disable PKCS1 key decoding plugin.])
+ARG_DISBL_SET([pkcs8], [disable PKCS8 private key decoding plugin.])
ARG_DISBL_SET([pgp], [disable PGP key decoding plugin.])
ARG_DISBL_SET([dnskey], [disable DNS RR key decoding plugin.])
ARG_DISBL_SET([pem], [disable PEM decoding plugin.])
ARG_DISBL_SET([hmac], [disable HMAC crypto implementation plugin.])
+ARG_DISBL_SET([cmac], [disable CMAC crypto implementation plugin.])
ARG_DISBL_SET([xcbc], [disable xcbc crypto implementation plugin.])
ARG_ENABL_SET([af-alg], [enable AF_ALG crypto interface to Linux Crypto API.])
ARG_ENABL_SET([test-vectors], [enable plugin providing crypto test vectors.])
@@ -108,30 +112,38 @@ ARG_ENABL_SET([smartcard], [enable smartcard support.])
ARG_ENABL_SET([cisco-quirks], [enable support of Cisco VPN client.])
ARG_ENABL_SET([leak-detective], [enable malloc hooks to find memory leaks.])
ARG_ENABL_SET([lock-profiler], [enable lock/mutex profiling code.])
-ARG_ENABL_SET([unit-tests], [enable unit tests on IKEv2 daemon startup.])
+ARG_ENABL_SET([unit-tester], [enable unit tests on IKEv2 daemon startup.])
ARG_ENABL_SET([load-tester], [enable load testing plugin for IKEv2 daemon.])
ARG_ENABL_SET([eap-sim], [enable SIM authentication module for EAP.])
ARG_ENABL_SET([eap-sim-file], [enable EAP-SIM backend based on a triplet file.])
ARG_ENABL_SET([eap-sim-pcsc], [enable EAP-SIM backend based on a smartcard reader. Requires libpcsclite.])
+ARG_ENABL_SET([eap-aka], [enable EAP AKA authentication module.])
+ARG_ENABL_SET([eap-aka-3gpp2], [enable EAP AKA backend implementing 3GPP2 algorithms in software. Requires libgmp.])
ARG_ENABL_SET([eap-simaka-sql], [enable EAP-SIM/AKA backend based on a triplet/quintuplet SQL database.])
ARG_ENABL_SET([eap-simaka-pseudonym], [enable EAP-SIM/AKA pseudonym storage plugin.])
ARG_ENABL_SET([eap-simaka-reauth], [enable EAP-SIM/AKA reauthentication data storage plugin.])
ARG_ENABL_SET([eap-identity], [enable EAP module providing EAP-Identity helper.])
ARG_ENABL_SET([eap-md5], [enable EAP MD5 (CHAP) authentication module.])
ARG_ENABL_SET([eap-gtc], [enable PAM based EAP GTC authentication module.])
-ARG_ENABL_SET([eap-aka], [enable EAP AKA authentication module.])
-ARG_ENABL_SET([eap-aka-3gpp2], [enable EAP AKA backend implementing 3GPP2 algorithms in software. Requires libgmp.])
ARG_ENABL_SET([eap-mschapv2], [enable EAP MS-CHAPv2 authentication module.])
ARG_ENABL_SET([eap-tls], [enable EAP TLS authentication module.])
ARG_ENABL_SET([eap-ttls], [enable EAP TTLS authentication module.])
ARG_ENABL_SET([eap-peap], [enable EAP PEAP authentication module.])
ARG_ENABL_SET([eap-tnc], [enable EAP TNC trusted network connect module.])
ARG_ENABL_SET([eap-radius], [enable RADIUS proxy authentication module.])
+ARG_ENABL_SET([tnc-ifmap], [enable TNC IF-MAP module.])
+ARG_ENABL_SET([tnc-pdp], [enable TNC policy decision point module.])
ARG_ENABL_SET([tnc-imc], [enable TNC IMC module.])
ARG_ENABL_SET([tnc-imv], [enable TNC IMV module.])
ARG_ENABL_SET([tnccs-11], [enable TNCCS 1.1 protocol module.])
ARG_ENABL_SET([tnccs-20], [enable TNCCS 2.0 protocol module.])
ARG_ENABL_SET([tnccs-dynamic], [enable dynamic TNCCS protocol discovery module.])
+ARG_ENABL_SET([imc-test], [enable IMC test module.])
+ARG_ENABL_SET([imv-test], [enable IMV test module.])
+ARG_ENABL_SET([imc-scanner], [enable IMC port scanner module.])
+ARG_ENABL_SET([imv-scanner], [enable IMV port scanner module.])
+ARG_ENABL_SET([imc-attestation],[enable IMC attestation module.])
+ARG_ENABL_SET([imv-attestation],[enable IMV attestation module.])
ARG_DISBL_SET([kernel-netlink], [disable the netlink kernel interface.])
ARG_ENABL_SET([kernel-pfkey], [enable the PF_KEY kernel interface.])
ARG_ENABL_SET([kernel-pfroute], [enable the PF_ROUTE kernel interface.])
@@ -152,6 +164,7 @@ ARG_DISBL_SET([load-warning], [disable the charon/pluto plugin load option war
ARG_DISBL_SET([pluto], [disable the IKEv1 keying daemon pluto.])
ARG_DISBL_SET([xauth], [disable xauth plugin.])
ARG_DISBL_SET([threads], [disable the use of threads in pluto. Charon always uses threads.])
+ARG_DISBL_SET([adns], [disable the use of adns in pluto (disables opportunistic encryption).])
ARG_DISBL_SET([charon], [disable the IKEv2 keying daemon charon.])
ARG_DISBL_SET([tools], [disable additional utilities (openac, scepclient and pki).])
ARG_DISBL_SET([scripts], [disable additional utilities (found in directory scripts).])
@@ -176,9 +189,11 @@ ARG_ENABL_SET([maemo], [enable Maemo specific plugin.])
ARG_ENABL_SET([nm], [enable NetworkManager plugin.])
ARG_ENABL_SET([ha], [enable high availability cluster plugin.])
ARG_ENABL_SET([whitelist], [enable peer identity whitelisting plugin.])
+ARG_ENABL_SET([certexpire], [enable CSV export of expiration dates of used certificates.])
ARG_ENABL_SET([led], [enable plugin to control LEDs on IKEv2 activity using the Linux kernel LED subsystem.])
ARG_ENABL_SET([duplicheck], [advanced duplicate checking plugin using liveness checks.])
ARG_ENABL_SET([coupling], [enable IKEv2 plugin to couple peer certificates permanently to authentication.])
+ARG_ENABL_SET([radattr], [enable plugin to inject and process custom RADIUS attributes as IKEv2 client.])
ARG_ENABL_SET([vstr], [enforce using the Vstr string library to replace glibc-like printf hooks.])
ARG_ENABL_SET([monolithic], [build monolithic version of libstrongswan that includes all enabled plugins. Similarly, the plugins of charon are assembled in libcharon.])
@@ -187,7 +202,7 @@ dnl set up compiler and flags
dnl =========================
if test -z "$CFLAGS"; then
- CFLAGS="-g -O2 -Wall -Wno-format -Wno-pointer-sign -Wno-strict-aliasing"
+ CFLAGS="-g -O2 -Wall -Wno-format -Wno-pointer-sign"
fi
AC_PROG_CC
AC_LIB_PREFIX
@@ -240,6 +255,22 @@ if test x$eap_tls = xtrue -o x$eap_ttls = xtrue -o x$eap_peap = xtrue; then
tls=true;
fi
+if test x$eap_radius = xtrue -o x$radattr = xtrue -o x$tnc_pdp = xtrue; then
+ radius=true;
+fi
+
+if test x$tnc_imc = xtrue -o x$tnc_imv = xtrue -o x$tnccs_11 = xtrue -o x$tnccs_11 = xtrue -o x$tnccs_dynamic = xtrue -o x$eap_tnc = xtrue; then
+ tnc_tnccs=true;
+fi
+
+if test x$imc_test = xtrue -o x$imv_test = xtrue -o x$imc_scanner = xtrue -o x$imv_scanner = xtrue -o x$imc_attestation = xtrue -o x$imv_attestation = xtrue; then
+ imcv=true;
+fi
+
+if test x$imc_attestation = xtrue -o x$imv_attestation = xtrue; then
+ pts=true;
+fi
+
if test x$fips_prf = xtrue; then
if test x$openssl = xfalse; then
sha1=true;
@@ -250,6 +281,10 @@ if test x$smp = xtrue -o x$tnccs_11 = xtrue; then
xml=true
fi
+if test x$tnc_ifmap = xtrue; then
+ axis2c=true
+fi
+
if test x$manager = xtrue; then
fast=true
fi
@@ -353,9 +388,23 @@ dnl check if native rwlocks are available
AC_CHECK_FUNCS(pthread_rwlock_init)
LIBS=$saved_LIBS
-AC_CHECK_FUNCS(prctl)
+AC_CHECK_FUNC(
+ [gettid],
+ [AC_DEFINE(HAVE_GETTID)],
+ [AC_MSG_CHECKING([for SYS_gettid])
+ AC_TRY_COMPILE(
+ [#define _GNU_SOURCE
+ #include <unistd.h>
+ #include <sys/syscall.h>],
+ [int main() {
+ return syscall(SYS_gettid);}],
+ [AC_MSG_RESULT([yes]); AC_DEFINE([HAVE_GETTID])
+ AC_DEFINE([HAVE_SYS_GETTID])],
+ [AC_MSG_RESULT([no])]
+ )]
+)
-AC_CHECK_FUNCS(mallinfo)
+AC_CHECK_FUNCS(prctl mallinfo getpass closefrom)
AC_CHECK_HEADERS(sys/sockio.h glob.h)
AC_CHECK_HEADERS(net/pfkeyv2.h netipsec/ipsec.h netinet6/ipsec.h linux/udp.h)
@@ -437,6 +486,17 @@ AC_TRY_COMPILE(
[AC_MSG_RESULT([no])]
)
+AC_MSG_CHECKING([for RTA_TABLE])
+AC_TRY_COMPILE(
+ [#include <sys/socket.h>
+ #include <linux/netlink.h>
+ #include <linux/rtnetlink.h>],
+ [int rta_type = RTA_TABLE;
+ return rta_type;],
+ [AC_MSG_RESULT([yes]); AC_DEFINE([HAVE_RTA_TABLE])],
+ [AC_MSG_RESULT([no])]
+)
+
AC_MSG_CHECKING([for gcc atomic operations])
AC_TRY_RUN(
[
@@ -524,6 +584,17 @@ if test x$xml = xtrue; then
AC_SUBST(xml_LIBS)
fi
+if test x$axis2c = xtrue; then
+ PKG_CHECK_MODULES(axis2c, [axis2c])
+ AC_SUBST(axis2c_CFLAGS)
+ AC_SUBST(axis2c_LIBS)
+fi
+
+if test x$imc_attestation = xtrue -o x$imv_attestation = xtrue; then
+ AC_HAVE_LIBRARY([tspi],[LIBS="$LIBS"],[AC_MSG_ERROR([TrouSerS library libtspi not found])])
+ AC_CHECK_HEADER([trousers/tss.h],,[AC_MSG_ERROR([TrouSerS header trousers/tss.h not found!])])
+fi
+
if test x$dumm = xtrue; then
PKG_CHECK_MODULES(gtk, [gtk+-2.0 vte])
AC_SUBST(gtk_CFLAGS)
@@ -557,7 +628,22 @@ fi
if test x$fast = xtrue; then
AC_HAVE_LIBRARY([neo_cgi],[LIBS="$LIBS"],[AC_MSG_ERROR([ClearSilver library neo_cgi not found!])])
AC_HAVE_LIBRARY([neo_utl],[LIBS="$LIBS"],[AC_MSG_ERROR([ClearSilver library neo_utl not found!])])
- AC_HAVE_LIBRARY([z],[LIBS="$LIBS"],[AC_MSG_ERROR([ClearSilver dependency zlib not found!])])
+ AC_MSG_CHECKING([ClearSilver requires zlib])
+ saved_CFLAGS=$CFLAGS
+ saved_LIBS=$LIBS
+ LIBS="-lneo_cgi -lneo_cs -lneo_utl"
+ CFLAGS="-I/usr/include/ClearSilver"
+ AC_TRY_LINK(
+ [#include <ClearSilver.h>],
+ [
+ NEOERR *err = cgi_display(NULL, NULL);
+ ],
+ [AC_MSG_RESULT([no]); clearsilver_LIBS="$LIBS"],
+ [AC_MSG_RESULT([yes]); clearsilver_LIBS="$LIBS -lz"]
+ )
+ AC_SUBST(clearsilver_LIBS)
+ LIBS=$saved_LIBS
+ CFLAGS=$saved_CFLAGS
dnl autoconf does not like CamelCase!? How to fix this?
dnl AC_CHECK_HEADER([ClearSilver/ClearSilver.h],,[AC_MSG_ERROR([ClearSilver header file ClearSilver/ClearSilver.h not found!])])
@@ -699,7 +785,9 @@ m4_include(m4/macros/add-plugin.m4)
# plugin lists for all components
libcharon_plugins=
pluto_plugins=
+starter_plugins=
pool_plugins=
+attest_plugins=
openac_plugins=
scepclient_plugins=
pki_plugins=
@@ -718,45 +806,47 @@ ADD_PLUGIN([test-vectors], [s libcharon pluto openac scepclient pki])
ADD_PLUGIN([curl], [s libcharon pluto scepclient scripts])
ADD_PLUGIN([soup], [s libcharon pluto scripts])
ADD_PLUGIN([ldap], [s libcharon pluto scepclient scripts])
-ADD_PLUGIN([mysql], [s libcharon pluto pool manager medsrv])
-ADD_PLUGIN([sqlite], [s libcharon pluto pool manager medsrv])
+ADD_PLUGIN([mysql], [s libcharon pluto pool manager medsrv attest])
+ADD_PLUGIN([sqlite], [s libcharon pluto pool manager medsrv attest])
+ADD_PLUGIN([pkcs11], [s libcharon pki])
ADD_PLUGIN([aes], [s libcharon pluto openac scepclient pki scripts])
ADD_PLUGIN([des], [s libcharon pluto openac scepclient pki scripts])
ADD_PLUGIN([blowfish], [s libcharon pluto openac scepclient pki scripts])
-ADD_PLUGIN([sha1], [s libcharon pluto openac scepclient pki scripts medsrv])
-ADD_PLUGIN([sha2], [s libcharon pluto openac scepclient pki scripts medsrv])
+ADD_PLUGIN([sha1], [s libcharon pluto openac scepclient pki scripts medsrv attest])
+ADD_PLUGIN([sha2], [s libcharon pluto openac scepclient pki scripts medsrv attest])
ADD_PLUGIN([md4], [s libcharon openac manager scepclient pki])
-ADD_PLUGIN([md5], [s libcharon pluto openac scepclient pki])
-ADD_PLUGIN([random], [s libcharon pluto openac scepclient pki scripts medsrv])
-ADD_PLUGIN([x509], [s libcharon pluto openac scepclient pki scripts])
+ADD_PLUGIN([md5], [s libcharon pluto openac scepclient pki scripts attest])
+ADD_PLUGIN([random], [s libcharon pluto openac scepclient pki scripts medsrv attest])
+ADD_PLUGIN([x509], [s libcharon pluto openac scepclient pki scripts attest])
ADD_PLUGIN([revocation], [s libcharon])
ADD_PLUGIN([constraints], [s libcharon])
ADD_PLUGIN([pubkey], [s libcharon])
-ADD_PLUGIN([pkcs1], [s libcharon pluto openac scepclient pki scripts manager medsrv])
+ADD_PLUGIN([pkcs1], [s libcharon pluto openac scepclient pki scripts manager medsrv attest])
+ADD_PLUGIN([pkcs8], [s libcharon pluto openac scepclient pki scripts manager medsrv attest])
ADD_PLUGIN([pgp], [s libcharon pluto])
ADD_PLUGIN([dnskey], [s pluto])
-ADD_PLUGIN([pem], [s libcharon pluto openac scepclient pki scripts manager medsrv])
+ADD_PLUGIN([pem], [s libcharon pluto openac scepclient pki scripts manager medsrv attest])
ADD_PLUGIN([padlock], [s libcharon])
-ADD_PLUGIN([openssl], [s libcharon pluto openac scepclient pki scripts manager medsrv])
-ADD_PLUGIN([gcrypt], [s libcharon pluto openac scepclient pki scripts manager medsrv])
+ADD_PLUGIN([openssl], [s libcharon pluto openac scepclient pki scripts manager medsrv attest])
+ADD_PLUGIN([gcrypt], [s libcharon pluto openac scepclient pki scripts manager medsrv attest])
+ADD_PLUGIN([af-alg], [s libcharon pluto openac scepclient pki scripts medsrv attest])
ADD_PLUGIN([fips-prf], [s libcharon])
-ADD_PLUGIN([gmp], [s libcharon pluto openac scepclient pki scripts manager medsrv])
+ADD_PLUGIN([gmp], [s libcharon pluto openac scepclient pki scripts manager medsrv attest])
ADD_PLUGIN([agent], [s libcharon])
-ADD_PLUGIN([pkcs11], [s libcharon pki])
ADD_PLUGIN([xcbc], [s libcharon])
+ADD_PLUGIN([cmac], [s libcharon])
ADD_PLUGIN([hmac], [s libcharon pluto scripts])
ADD_PLUGIN([ctr], [s libcharon scripts])
ADD_PLUGIN([ccm], [s libcharon scripts])
ADD_PLUGIN([gcm], [s libcharon scripts])
-ADD_PLUGIN([af-alg], [s libcharon pluto openac scepclient pki scripts medsrv])
ADD_PLUGIN([xauth], [p pluto])
ADD_PLUGIN([attr], [h libcharon pluto])
ADD_PLUGIN([attr-sql], [h libcharon pluto])
ADD_PLUGIN([load-tester], [c libcharon])
-ADD_PLUGIN([kernel-pfkey], [h libcharon pluto])
-ADD_PLUGIN([kernel-pfroute], [h libcharon pluto])
-ADD_PLUGIN([kernel-klips], [h libcharon pluto])
-ADD_PLUGIN([kernel-netlink], [h libcharon pluto])
+ADD_PLUGIN([kernel-pfkey], [h libcharon pluto starter])
+ADD_PLUGIN([kernel-pfroute], [h libcharon pluto starter])
+ADD_PLUGIN([kernel-klips], [h libcharon pluto starter])
+ADD_PLUGIN([kernel-netlink], [h libcharon pluto starter])
ADD_PLUGIN([resolve], [h libcharon pluto])
ADD_PLUGIN([socket-default], [c libcharon])
ADD_PLUGIN([socket-raw], [c libcharon])
@@ -770,11 +860,11 @@ ADD_PLUGIN([eap-identity], [c libcharon])
ADD_PLUGIN([eap-sim], [c libcharon])
ADD_PLUGIN([eap-sim-file], [c libcharon])
ADD_PLUGIN([eap-sim-pcsc], [c libcharon])
+ADD_PLUGIN([eap-aka], [c libcharon])
+ADD_PLUGIN([eap-aka-3gpp2], [c libcharon])
ADD_PLUGIN([eap-simaka-sql], [c libcharon])
ADD_PLUGIN([eap-simaka-pseudonym], [c libcharon])
ADD_PLUGIN([eap-simaka-reauth], [c libcharon])
-ADD_PLUGIN([eap-aka], [c libcharon])
-ADD_PLUGIN([eap-aka-3gpp2], [c libcharon])
ADD_PLUGIN([eap-md5], [c libcharon])
ADD_PLUGIN([eap-gtc], [c libcharon])
ADD_PLUGIN([eap-mschapv2], [c libcharon])
@@ -783,11 +873,14 @@ ADD_PLUGIN([eap-tls], [c libcharon])
ADD_PLUGIN([eap-ttls], [c libcharon])
ADD_PLUGIN([eap-peap], [c libcharon])
ADD_PLUGIN([eap-tnc], [c libcharon])
+ADD_PLUGIN([tnc-ifmap], [c libcharon])
+ADD_PLUGIN([tnc-pdp], [c libcharon])
+ADD_PLUGIN([tnc-imc], [c libcharon])
+ADD_PLUGIN([tnc-imv], [c libcharon])
+ADD_PLUGIN([tnc-tnccs], [c libcharon])
ADD_PLUGIN([tnccs-20], [c libcharon])
ADD_PLUGIN([tnccs-11], [c libcharon])
ADD_PLUGIN([tnccs-dynamic], [c libcharon])
-ADD_PLUGIN([tnc-imc], [c libcharon])
-ADD_PLUGIN([tnc-imv], [c libcharon])
ADD_PLUGIN([medsrv], [c libcharon])
ADD_PLUGIN([medcli], [c libcharon])
ADD_PLUGIN([nm], [c libcharon])
@@ -795,9 +888,11 @@ ADD_PLUGIN([dhcp], [c libcharon])
ADD_PLUGIN([android], [c libcharon])
ADD_PLUGIN([ha], [c libcharon])
ADD_PLUGIN([whitelist], [c libcharon])
+ADD_PLUGIN([certexpire], [c libcharon])
ADD_PLUGIN([led], [c libcharon])
ADD_PLUGIN([duplicheck], [c libcharon])
ADD_PLUGIN([coupling], [c libcharon])
+ADD_PLUGIN([radattr], [c libcharon])
ADD_PLUGIN([maemo], [c libcharon])
ADD_PLUGIN([uci], [c libcharon])
ADD_PLUGIN([addrblock], [c libcharon])
@@ -805,7 +900,9 @@ ADD_PLUGIN([unit-tester], [c libcharon])
AC_SUBST(libcharon_plugins)
AC_SUBST(pluto_plugins)
+AC_SUBST(starter_plugins)
AC_SUBST(pool_plugins)
+AC_SUBST(attest_plugins)
AC_SUBST(openac_plugins)
AC_SUBST(scepclient_plugins)
AC_SUBST(pki_plugins)
@@ -843,10 +940,12 @@ AM_CONDITIONAL(USE_REVOCATION, test x$revocation = xtrue)
AM_CONDITIONAL(USE_CONSTRAINTS, test x$constraints = xtrue)
AM_CONDITIONAL(USE_PUBKEY, test x$pubkey = xtrue)
AM_CONDITIONAL(USE_PKCS1, test x$pkcs1 = xtrue)
+AM_CONDITIONAL(USE_PKCS8, test x$pkcs8 = xtrue)
AM_CONDITIONAL(USE_PGP, test x$pgp = xtrue)
AM_CONDITIONAL(USE_DNSKEY, test x$dnskey = xtrue)
AM_CONDITIONAL(USE_PEM, test x$pem = xtrue)
AM_CONDITIONAL(USE_HMAC, test x$hmac = xtrue)
+AM_CONDITIONAL(USE_CMAC, test x$cmac = xtrue)
AM_CONDITIONAL(USE_XCBC, test x$xcbc = xtrue)
AM_CONDITIONAL(USE_MYSQL, test x$mysql = xtrue)
AM_CONDITIONAL(USE_SQLITE, test x$sqlite = xtrue)
@@ -873,13 +972,15 @@ AM_CONDITIONAL(USE_SMP, test x$smp = xtrue)
AM_CONDITIONAL(USE_SQL, test x$sql = xtrue)
AM_CONDITIONAL(USE_UPDOWN, test x$updown = xtrue)
AM_CONDITIONAL(USE_DHCP, test x$dhcp = xtrue)
-AM_CONDITIONAL(USE_UNIT_TESTS, test x$unit_tests = xtrue)
+AM_CONDITIONAL(USE_UNIT_TESTS, test x$unit_tester = xtrue)
AM_CONDITIONAL(USE_LOAD_TESTER, test x$load_tester = xtrue)
AM_CONDITIONAL(USE_HA, test x$ha = xtrue)
AM_CONDITIONAL(USE_WHITELIST, test x$whitelist = xtrue)
+AM_CONDITIONAL(USE_CERTEXPIRE, test x$certexpire = xtrue)
AM_CONDITIONAL(USE_LED, test x$led = xtrue)
AM_CONDITIONAL(USE_DUPLICHECK, test x$duplicheck = xtrue)
AM_CONDITIONAL(USE_COUPLING, test x$coupling = xtrue)
+AM_CONDITIONAL(USE_RADATTR, test x$radattr = xtrue)
AM_CONDITIONAL(USE_EAP_SIM, test x$eap_sim = xtrue)
AM_CONDITIONAL(USE_EAP_SIM_FILE, test x$eap_sim_file = xtrue)
AM_CONDITIONAL(USE_EAP_SIM_PCSC, test x$eap_sim_pcsc = xtrue)
@@ -897,11 +998,20 @@ AM_CONDITIONAL(USE_EAP_TTLS, test x$eap_ttls = xtrue)
AM_CONDITIONAL(USE_EAP_PEAP, test x$eap_peap = xtrue)
AM_CONDITIONAL(USE_EAP_TNC, test x$eap_tnc = xtrue)
AM_CONDITIONAL(USE_EAP_RADIUS, test x$eap_radius = xtrue)
+AM_CONDITIONAL(USE_TNC_IFMAP, test x$tnc_ifmap = xtrue)
+AM_CONDITIONAL(USE_TNC_PDP, test x$tnc_pdp = xtrue)
AM_CONDITIONAL(USE_TNC_IMC, test x$tnc_imc = xtrue)
AM_CONDITIONAL(USE_TNC_IMV, test x$tnc_imv = xtrue)
+AM_CONDITIONAL(USE_TNC_TNCCS, test x$tnc_tnccs = xtrue)
AM_CONDITIONAL(USE_TNCCS_11, test x$tnccs_11 = xtrue)
AM_CONDITIONAL(USE_TNCCS_20, test x$tnccs_20 = xtrue)
AM_CONDITIONAL(USE_TNCCS_DYNAMIC, test x$tnccs_dynamic = xtrue)
+AM_CONDITIONAL(USE_IMC_TEST, test x$imc_test = xtrue)
+AM_CONDITIONAL(USE_IMV_TEST, test x$imv_test = xtrue)
+AM_CONDITIONAL(USE_IMC_SCANNER, test x$imc_scanner = xtrue)
+AM_CONDITIONAL(USE_IMV_SCANNER, test x$imv_scanner = xtrue)
+AM_CONDITIONAL(USE_IMC_ATTESTATION, test x$imc_attestation = xtrue)
+AM_CONDITIONAL(USE_IMV_ATTESTATION, test x$imv_attestation = xtrue)
AM_CONDITIONAL(USE_SOCKET_DEFAULT, test x$socket_default = xtrue)
AM_CONDITIONAL(USE_SOCKET_RAW, test x$socket_raw = xtrue)
AM_CONDITIONAL(USE_SOCKET_DYNAMIC, test x$socket_dynamic = xtrue)
@@ -939,19 +1049,25 @@ AM_CONDITIONAL(USE_INTEGRITY_TEST, test x$integrity_test = xtrue)
AM_CONDITIONAL(USE_LOAD_WARNING, test x$load_warning = xtrue)
AM_CONDITIONAL(USE_PLUTO, test x$pluto = xtrue)
AM_CONDITIONAL(USE_THREADS, test x$threads = xtrue)
+AM_CONDITIONAL(USE_ADNS, test x$adns = xtrue)
AM_CONDITIONAL(USE_CHARON, test x$charon = xtrue)
AM_CONDITIONAL(USE_TOOLS, test x$tools = xtrue)
AM_CONDITIONAL(USE_SCRIPTS, test x$scripts = xtrue)
AM_CONDITIONAL(USE_CONFTEST, test x$conftest = xtrue)
-AM_CONDITIONAL(USE_LIBSTRONGSWAN, test x$charon = xtrue -o x$pluto = xtrue -o x$tools = xtrue -o x$conftest = xtrue)
+AM_CONDITIONAL(USE_LIBSTRONGSWAN, test x$charon = xtrue -o x$pluto = xtrue -o x$tools = xtrue -o x$conftest = xtrue -o x$fast = xtrue -o x$imcv = xtrue)
AM_CONDITIONAL(USE_LIBHYDRA, test x$charon = xtrue -o x$pluto = xtrue)
AM_CONDITIONAL(USE_LIBCHARON, test x$charon = xtrue -o x$conftest = xtrue)
+AM_CONDITIONAL(USE_LIBTNCIF, test x$tnc_tnccs = xtrue -o x$imcv = xtrue)
+AM_CONDITIONAL(USE_LIBTNCCS, test x$tnc_tnccs = xtrue)
AM_CONDITIONAL(USE_FILE_CONFIG, test x$pluto = xtrue -o x$stroke = xtrue)
AM_CONDITIONAL(USE_IPSEC_SCRIPT, test x$pluto = xtrue -o x$stroke = xtrue -o x$tools = xtrue -o x$conftest = xtrue)
AM_CONDITIONAL(USE_LIBCAP, test x$capabilities = xlibcap)
AM_CONDITIONAL(USE_VSTR, test x$vstr = xtrue)
AM_CONDITIONAL(USE_SIMAKA, test x$simaka = xtrue)
AM_CONDITIONAL(USE_TLS, test x$tls = xtrue)
+AM_CONDITIONAL(USE_RADIUS, test x$radius = xtrue)
+AM_CONDITIONAL(USE_IMCV, test x$imcv = xtrue)
+AM_CONDITIONAL(USE_PTS, test x$pts = xtrue)
AM_CONDITIONAL(MONOLITHIC, test x$monolithic = xtrue)
dnl ==============================
@@ -982,6 +1098,7 @@ AC_OUTPUT(
src/include/Makefile
src/libstrongswan/Makefile
src/libstrongswan/plugins/aes/Makefile
+ src/libstrongswan/plugins/cmac/Makefile
src/libstrongswan/plugins/des/Makefile
src/libstrongswan/plugins/blowfish/Makefile
src/libstrongswan/plugins/md4/Makefile
@@ -998,6 +1115,7 @@ AC_OUTPUT(
src/libstrongswan/plugins/constraints/Makefile
src/libstrongswan/plugins/pubkey/Makefile
src/libstrongswan/plugins/pkcs1/Makefile
+ src/libstrongswan/plugins/pkcs8/Makefile
src/libstrongswan/plugins/pgp/Makefile
src/libstrongswan/plugins/dnskey/Makefile
src/libstrongswan/plugins/pem/Makefile
@@ -1027,6 +1145,17 @@ AC_OUTPUT(
src/libfreeswan/Makefile
src/libsimaka/Makefile
src/libtls/Makefile
+ src/libradius/Makefile
+ src/libtncif/Makefile
+ src/libtnccs/Makefile
+ src/libpts/Makefile
+ src/libpts/plugins/imc_attestation/Makefile
+ src/libpts/plugins/imv_attestation/Makefile
+ src/libimcv/Makefile
+ src/libimcv/plugins/imc_test/Makefile
+ src/libimcv/plugins/imv_test/Makefile
+ src/libimcv/plugins/imc_scanner/Makefile
+ src/libimcv/plugins/imv_scanner/Makefile
src/pluto/Makefile
src/pluto/plugins/xauth/Makefile
src/whack/Makefile
@@ -1049,8 +1178,11 @@ AC_OUTPUT(
src/libcharon/plugins/eap_peap/Makefile
src/libcharon/plugins/eap_tnc/Makefile
src/libcharon/plugins/eap_radius/Makefile
+ src/libcharon/plugins/tnc_ifmap/Makefile
+ src/libcharon/plugins/tnc_pdp/Makefile
src/libcharon/plugins/tnc_imc/Makefile
src/libcharon/plugins/tnc_imv/Makefile
+ src/libcharon/plugins/tnc_tnccs/Makefile
src/libcharon/plugins/tnccs_11/Makefile
src/libcharon/plugins/tnccs_20/Makefile
src/libcharon/plugins/tnccs_dynamic/Makefile
@@ -1067,9 +1199,11 @@ AC_OUTPUT(
src/libcharon/plugins/uci/Makefile
src/libcharon/plugins/ha/Makefile
src/libcharon/plugins/whitelist/Makefile
+ src/libcharon/plugins/certexpire/Makefile
src/libcharon/plugins/led/Makefile
src/libcharon/plugins/duplicheck/Makefile
src/libcharon/plugins/coupling/Makefile
+ src/libcharon/plugins/radattr/Makefile
src/libcharon/plugins/android/Makefile
src/libcharon/plugins/maemo/Makefile
src/libcharon/plugins/stroke/Makefile