summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/01_fix-manpages.patch41
-rw-r--r--debian/patches/02_fix-printf-dnssec-script.patch91
-rw-r--r--debian/patches/series2
3 files changed, 134 insertions, 0 deletions
diff --git a/debian/patches/01_fix-manpages.patch b/debian/patches/01_fix-manpages.patch
new file mode 100644
index 000000000..656882939
--- /dev/null
+++ b/debian/patches/01_fix-manpages.patch
@@ -0,0 +1,41 @@
+--- a/src/_updown/_updown.8
++++ b/src/_updown/_updown.8
+@@ -1,6 +1,6 @@
+ .TH _UPDOWN 8 "27 Apr 2006"
+ .SH NAME
+-ipsec _updown \- route and firewall manipulation script
++ipsec_updown \- route and firewall manipulation script
+ .SH SYNOPSIS
+ .I _updown
+ is invoked by pluto when it has brought up a new connection. This script
+--- a/src/_updown_espmark/_updown_espmark.8
++++ b/src/_updown_espmark/_updown_espmark.8
+@@ -1,6 +1,6 @@
+ .TH _UPDOWN_ESPMARK 8 "7 Apr 2005"
+ .SH NAME
+-ipsec _updown_espmark \- manages routes and firewall rules
++ipsec_updown_espmark \- manages routes and firewall rules
+ .SH SYNOPSIS
+ .I _updown_espmark
+ is invoked by pluto when it has brought up a new connection. This script
+--- a/src/openac/openac.8
++++ b/src/openac/openac.8
+@@ -1,6 +1,6 @@
+ .TH IPSEC_OPENAC 8 "22 September 2007"
+ .SH NAME
+-ipsec openac \- Generation of X.509 attribute certificates
++ipsec_openac \- Generation of X.509 attribute certificates
+ .SH SYNOPSIS
+ .B ipsec
+ .B openac
+--- a/src/scepclient/scepclient.8
++++ b/src/scepclient/scepclient.8
+@@ -1,7 +1,7 @@
+ .\"
+ .TH "IPSEC_SCEPCLIENT" "8" "2012-05-11" "strongSwan" ""
+ .SH "NAME"
+-ipsec scepclient \- Client for the SCEP protocol
++ipsec_scepclient \- Client for the SCEP protocol
+ .SH "SYNOPSIS"
+ .B ipsec scepclient [argument ...]
+ .sp
diff --git a/debian/patches/02_fix-printf-dnssec-script.patch b/debian/patches/02_fix-printf-dnssec-script.patch
new file mode 100644
index 000000000..1015a08ad
--- /dev/null
+++ b/debian/patches/02_fix-printf-dnssec-script.patch
@@ -0,0 +1,91 @@
+From 1a185ae14b5073d0d5358ff5e2a98d2ff07d7558 Mon Sep 17 00:00:00 2001
+From: Andreas Steffen <andreas.steffen@strongswan.org>
+Date: Mon, 8 Apr 2013 22:21:14 +0200
+Subject: [PATCH] fixed printf statements
+
+---
+ configure.in | 2 +-
+ scripts/dnssec.c | 37 ++++++++++++++++++++++++++++---------
+ 2 files changed, 29 insertions(+), 10 deletions(-)
+
+--- a/scripts/dnssec.c
++++ b/scripts/dnssec.c
+@@ -16,25 +16,47 @@
+ #include <stdio.h>
+
+ #include <library.h>
++#include <utils/debug.h>
++
++/**
++ * Define debug level
++ */
++static level_t dbg_level = 1;
++
++static void dbg_dnssec(debug_t group, level_t level, char *fmt, ...)
++{
++ if ((level <= dbg_level) || level <= 1)
++ {
++ va_list args;
++
++ va_start(args, fmt);
++ vfprintf(stderr, fmt, args);
++ fprintf(stderr, "\n");
++ va_end(args);
++ }
++}
+
+ int main(int argc, char *argv[])
+ {
+ resolver_t *resolver;
+ resolver_response_t *response;
+ enumerator_t *enumerator;
++ chunk_t rdata;
+ rr_set_t *rrset;
+ rr_t *rr;
+- chunk_t chunk;
+
+ library_init(NULL);
+ atexit(library_deinit);
++
++ dbg = dbg_dnssec;
++
+ if (!lib->plugins->load(lib->plugins, NULL, PLUGINS))
+ {
+ return 1;
+ }
+ if (argc != 2)
+ {
+- fprintf(stderr, "usage: %s <name>\n", argv[0]);
++ fprintf(stderr, "usage: dnssec <name>\n");
+ return 1;
+ }
+
+@@ -82,9 +104,7 @@ int main(int argc, char *argv[])
+ enumerator = rrset->create_rr_enumerator(rrset);
+ while (enumerator->enumerate(enumerator, &rr))
+ {
+- printf(" name: ");
+- printf(rr->get_name(rr));
+- printf("\n");
++ printf(" name: %s\n", rr->get_name(rr));
+ }
+
+ enumerator = rrset->create_rrsig_enumerator(rrset);
+@@ -93,13 +113,10 @@ int main(int argc, char *argv[])
+ printf(" RRSIGs for the RRset:\n");
+ while (enumerator->enumerate(enumerator, &rr))
+ {
+- printf(" name: ");
+- printf(rr->get_name(rr));
+- printf("\n RDATA: ");
+- chunk = rr->get_rdata(rr);
+- chunk = chunk_to_hex(chunk, NULL, TRUE);
+- printf(chunk.ptr);
+- printf("\n");
++ rdata = rr->get_rdata(rr);
++
++ printf(" name: %s\n", rr->get_name(rr));
++ printf(" RDATA: %#B\n", &rdata);
+ }
+ }
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 000000000..938b8a0ef
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+01_fix-manpages.patch
+02_fix-printf-dnssec-script.patch